Ask Your Question
0

Why Red Hat Virtio Driver/Windows is slow in Debian and fast in CentOS?

asked 2014-12-07 18:31:42 -0600

I had installed Juno OpenStack for Debian. Using Kvm, kvm_intel.

After I build VM follow up Image Guide - linux vm (debian, ubuntu) work pretty fast - 170Mbit/s.

In the mean time MS Windows machines - XP 32 bit, XP 64 bit and Windows 7 - are slow - 1 mbit/s or 10 after setup "tso off" on network card. Host's itself speed is normal - up to 170.

If I build VM with same images under CentOS 6,5 with no cloud services there I have no slow down with Windows.

If I do not want to migrate from Debian to CentOS anybody has a clue?

How to troubleshoot this or what virtio driver to try?

edit retag flag offensive close merge delete

Comments

I would compare versions of Qemu and Libvirt on Ubuntu Trusty with versions Qemu, Libvirt on Debian you are running.

samfrid gravatar imagesamfrid ( 2014-12-07 23:41:37 -0600 )edit

Thanks. I can tell versions are different on Centos 6.5 and Debian 7. I did not install compute node with Ubuntu Trusty. Virtual machine with Ubuntu Trusty is fast as expected. But Windows built with same virt-manger goes slow. Question: if I see that versions are different what to do?Reinstall?

szemtsov gravatar imageszemtsov ( 2014-12-08 20:16:42 -0600 )edit

I would try Ubuntu Trusty as host box.

samfrid gravatar imagesamfrid ( 2014-12-10 02:50:03 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-12-08 20:28:46 -0600

updated 2014-12-12 06:45:41 -0600

I replaced 3.2 kernel for latest kernel 3.10 and it was helpful. Inside 3.2 kernel that comes from mirrors virtio features are tagged as "experimental" but in 3.10 no tags like this so I believe they are fixing something.

I mean after installing new 3.10 kernel I have maximum of download and upload bandwidth for Windows 7 same I have on host interface

So I recommend THIS solution for Debian users.


I appreciate.

In fact I disabled already both tso and gro. It becomes bit faster from 1 to 10 but I expect 150. I heard about MTU. But I will try tomorrow to disable overload on all nova interfaces. And I did not start neutron.

If this is kernel issue so is anybody capable to come through menuconfig and disable something there? Any forum with kernel gurus?

Is it any clue that windows and freebsd instances are affected not linux...

Or if I install older kernel or start over with debian squeze - how that python juno repository works - can I use all services as expected?

edit flag offensive delete link more
1

answered 2014-12-08 14:10:15 -0600

mpetason gravatar image

updated 2014-12-08 14:15:55 -0600

Try turning off GRO as well, or any flags on the network interfaces that aren't actually needed.

ethtool -K eth0 gro off

You can run this on a few of the nodes for each of the interfaces associated with VM traffic.

I ran into the same issue when using Neutron + GRE - it was fixed with the GRO flag being turned off. Other guides may have you set a custom MTU that is smaller than 1500 to accommodate for the size. This would be the second thing to look into, such as setting the MTU so that when an instance comes up it gets 1454 or something lower than 1500.

On a side note I think it has to do with the newer kernel on Debian based machines + newer versions of packages such as OVS. Turning off overhead on your current infrastructure is what we can do to get the speed more manageable.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-07 18:31:42 -0600

Seen: 1,797 times

Last updated: Dec 12 '14