Ask Your Question

nova service state all down

asked 2014-12-05 01:45:45 -0500

Glen.GZ gravatar image

updated 2014-12-05 03:52:03 -0500

dbaxps gravatar image

i was following juno on ubuntu step by step. but some issues had to make me stop and look back when i was installing and configuring on compute-node. it turns out that all my nova service state is not up.

root@controller:~# nova service-list
| Id | Binary           | Host       | Zone     | Status  | State | Updated_at | Disabled Reason |
| 1  | nova-cert        | controller | internal | enabled | down  | -          | -               |
| 2  | nova-consoleauth | controller | internal | enabled | down  | -          | -               |
| 3  | nova-scheduler   | controller | internal | enabled | down  | -          | -               |
| 4  | nova-conductor   | controller | internal | enabled | down  | -          | -               |

what's more, controller couldn't detect nova-compute from compute node.
here is some log from compute node

2014-12-05 15:36:07.534 7958 INFO oslo.messaging._drivers.impl_rabbit [req-6e1f6d33-cb78-4e83-a58a-0751a0fef2e2 ] Delaying reconnect for 1.0 seconds...
2014-12-05 15:36:08.536 7958 INFO oslo.messaging._drivers.impl_rabbit [req-6e1f6d33-cb78-4e83-a58a-0751a0fef2e2 ] Connecting to AMQP server on controller:5672
2014-12-05 15:36:11.556 7958 ERROR oslo.messaging._drivers.impl_rabbit [req-6e1f6d33-cb78-4e83-a58a-0751a0fef2e2 ] AMQP server controller:5672 closed the connection. Check login credentials: Socket closed

telnet to controller 5672 port is ok. root@compute:/home# telnet controller 5672 Trying Connected to controller. Escape character is '^]'. Connection closed by foreign host.

here is part of setting on /etc/nova/nova.conf, im pretty sure that network connection among controller, compute and network is good. and i checked the rabbit_password is matched.

my_ip =
rabbit_host = controller
auth_strategy = keystone
my_ip =
vnc_enabled = True
vncserver_listen =
vncserver_proxyclient_address =
novncproxy_base_url = http://controller:6080/vnc_auto.html

auth_uri = http://controller:5000/v2.0
identity_uri = http://controller:35357
admin_tenant_name = service
admin_user = nova
admin_password = 12345

host = controller

the following is nova.conf on controller

rpc_backend = rabbit
rabbit_host = controller
auth_strategy = keystone
my_ip =
vncserver_listen =
vncserver_proxyclient_address =
verbose = True

i have no idea where goes wrong.

edit retag flag offensive close merge delete


Verify rabbitmq-server status on Controller per

dbaxps gravatar imagedbaxps ( 2014-12-05 03:58:29 -0500 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2014-12-05 07:33:57 -0500

rajiv-kumar gravatar image

I think you need to change the password of the rabbitmq with the following command

              rabbitmqctl change_password guest RABBIT_PASS

You must check you rabbitmq log. if you are getting error in rabbitmq log, something like "guest user is allowed only for local host" then you can try following two things,

1) By default guest user is used by the services. Some people got strange error, If the modify password of the guest account, and if it(password) is not the "guest" then they got above problem, but if they modified the password back to guest they got everything working.

2) i got this problem solved by creating a new user on the rabbitmq server and assign permission to it. Then add rabbit_userid = rabbitmq_username in default section of the configuration file of every service. Ofcourse modfiy the rabbit_password with the password of the newly created user.

edit flag offensive delete link more


thanks a lot. i think it is a problem of rabbit_guest account. i tried to change the guest password and reset in all .conf profiles, not work out. then i created a new account on rabbitmq server and assign permission. all the service state are up after restarting them. no i can continue the rest.

Glen.GZ gravatar imageGlen.GZ ( 2014-12-08 01:09:04 -0500 )edit

Thank you so much. I have tried many ways but your ways succeeded!

ducnv gravatar imageducnv ( 2017-03-06 05:39:50 -0500 )edit

Worked for me too. Reset guest account password to "guest". ensure the created account passwords are same in the .conf file in both Controller and all computing nodes. Thanks guys for the help.

tarek.awadallah gravatar imagetarek.awadallah ( 2017-03-23 03:24:38 -0500 )edit

answered 2016-06-13 09:02:28 -0500

RichArt gravatar image

Hi, this worked for me. I tried to change the password with:

rabbitmqctl change_password openstack RABBIT_PASS

then I realized that no "openstack" user existed. So, I created the user:

rabbitmqctl add_user openstack RABBIT_PASS
rabbitmqctl set_permissions openstack ".*" ".*" ".*"

That's it.

Dont forget to restart the nova-compute service again on all hosts:

sudo service nova-compute restart

Thanks a lot! :-)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-12-05 01:45:45 -0500

Seen: 4,148 times

Last updated: Jun 13 '16