Ask Your Question
1

devstack multi-node lab compute node fails

asked 2014-12-04 05:13:19 -0500

Kashyap Kopparam gravatar image

updated 2014-12-08 06:09:27 -0500

I am trying to setup the mutil-node devstack setup http://docs.openstack.org/developer/d... . I can install devstack on the controller node just fine. But while adding a compute node, devstack fails with

2014-12-04 10:43:31.826 | + cinder type-create lvmdriver-1
2014-12-04 10:43:32.127 | ERROR: Unable to establish connection to http://127.0.0.1:5000/v2.0/tokens
2014-12-04 10:43:32.148 | ++ err_trap
2014-12-04 10:43:32.148 | ++ local r=1
2014-12-04 10:43:32.148 | stack.sh failed: full log in /opt/stack/logs/stack.sh.log.2014-12-04-161234
2014-12-04 10:43:32.148 | Error on exit

I have made sure that the endpoints in the controller have routable IPs, but for some reason the keystone client on the compute node thinks the auth uri is the loopback ip. How can change it to have the routable ip?

I have been reproducing this error multiple times with different approaches. I tried having the two nodes in a private network of vagrant boxes, tried with two physical machines running Ubuntu. But I'm not able to solve this issue. Any inputs are greatly appreciated.

Controller local.conf

[[local|localrc]]
HOST_IP=10.4.1.255
FLAT_INTERFACE=eth0
FIXED_RANGE=192.168.0.0/20
FIXED_NETWORK_SIZE=4096
FLOATING_RANGE=10.4.2.0/28
# Credentials
DATABASE_PASSWORD=secrete
ADMIN_PASSWORD=secrete
SERVICE_PASSWORD=secrete
SERVICE_TOKEN=secrete
RABBIT_PASSWORD=secrete
MULTI_HOST=1

# Enable Logging
LOGFILE=/opt/stack/logs/stack.sh.log
VERBOSE=True
LOG_COLOR=True
SCREEN_LOGDIR=/opt/stack/logs
RECLONE=yes

Compute local.conf

[[local|localrc]]
HOST_IP=10.4.1.208
FLAT_INTERFACE=eth0
FIXED_RANGE=192.168.0.0/20
FIXED_NETWORK_SIZE=4096
FLOATING_RANGE=10.4.2.0/28
MULTI_HOST=1
LOGFILE=/opt/stack/logs/stack.sh.log
ADMIN_PASSWORD=secrete
MYSQL_PASSWORD=secrete
RABBIT_PASSWORD=secrete
SERVICE_PASSWORD=secrete
SERVICE_TOKEN=secrete
DATABASE_TYPE=mysql
SERVICE_HOST=10.4.1.255
MYSQL_HOST=10.4.1.255
RABBIT_HOST=10.4.1.255
GLANCE_HOSTPORT=10.4.1.255:9292
ENABLED_SERVICES=n-cpu,n-net,n-api,c-sch,c-api,c-vol
NOVA_VNC_ENABLED=True
NOVNCPROXY_URL="http://10.4.1.255:6080/vnc_auto.html"
VNCSERVER_LISTEN=$HOST_IP
VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN
edit retag flag offensive close merge delete

Comments

you might have wrongly configured local.conf, please share local.conf for both controller and compute.

yatin gravatar imageyatin ( 2014-12-04 07:54:47 -0500 )edit

Updated local.conf

Kashyap Kopparam gravatar imageKashyap Kopparam ( 2014-12-08 05:58:03 -0500 )edit

Hi, You can change your controller node IP to normal IP(not end by 255), maybe "10.4.1.210".

Ying Zou gravatar imageYing Zou ( 2014-12-10 20:47:44 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-12-09 04:44:16 -0500

Kashyap Kopparam gravatar image

I solved this issue by using devstack-vagrant https://github.com/openstack-dev/devs... . Well I dint solve the issue, but got a workaround. :)

edit flag offensive delete link more
0

answered 2014-12-04 21:17:53 -0500

updated 2014-12-05 03:02:45 -0500

I meet the some trouble.
My devstack has Two nodes,
1 - controller node
2 - compute node

First, I setup controller node, then when I setup the second node (compute node), I meet this trouble, I just run:
cinder type-list
cinder type-delete {lvmdriver-1-id}

On compute node: unstack.sh and stack.sh.

edit flag offensive delete link more

Comments

I often run into this problem as well. But the stack fails much before this problem occurs.

Kashyap Kopparam gravatar imageKashyap Kopparam ( 2014-12-08 01:13:18 -0500 )edit
0

answered 2015-01-22 00:45:21 -0500

Rajeshwar Mukund gravatar image

Please change IP address of your nodes. current local.conf have following settings.

HOST_IP=10.4.1.255 FLAT_INTERFACE=eth0 FIXED_RANGE=192.168.0.0/20 FIXED_NETWORK_SIZE=4096 FLOATING_RANGE=10.4.2.0/28

host IP address canno't be .255 as it is broadcast ip address also if you are defining Floating ip pool of netmask /28 so max possible addresses are 10.4.2.0 - 10.4.2.15 in this network host usable ips are from 10.4.2.1 to 10.4.2.14 & .15 will be your broadcast address.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-12-04 05:13:19 -0500

Seen: 870 times

Last updated: Jan 22 '15