Ask Your Question
1

Module openvswitch not found when starting openvswitch service

asked 2014-12-04 03:27:08 -0500

Mars gravatar image

updated 2014-12-05 17:55:19 -0500

smaffulli gravatar image

I am new for Openstack, in these days I've been trying to install an openstack Icehouse infrastructer with three nodes (controller node + network node + compute node) by following the offcial installation documentation for CentOS. When I finished the installation of neutron on the network node in chapter 7: Add a networking service, and trying to start openvswitch service. Here comes the error:

[root@network ~]# service openvswitch start
ovsdb-server is already running.
Inserting openvswitch module FATAL: Module openvswitch not found.
[FAILED]
Enabling remote OVSDB managers [  OK  ]


[root@network ~]# service openvswitch status
ovsdb-server is running with pid 2540
ovs-vswitchd is not running

Actually I am very sure I've installed all the necessary rpms for neutron service on the network node (openstack-neutron + openstack-neutron-ml2 + openstack-neutron-openvswitch) and configured all the necessary parameters carefully. I really don't see this error coming.

[root@TEST~~ ~]# rpm -qa |grep openvswitch-
openstack-neutron-openvswitch-2014.1.3-4.el6.noarch
openvswitch-2.1.2-1.el6.x86_64

Could you please help me to fix this problem?

Here is the basic information for my environment: CentOS 6.5 + Icehouse + Three-node architecture with Openstack Networking (neutron)

edit retag flag offensive close merge delete

Comments

@dbaxps this seems like a FAQ. If instead of writing comments you write and update an answer as you go, this question will become a guide for debugging similar issues. It'll be a lot more useful for future readers

smaffulli gravatar imagesmaffulli ( 2014-12-05 17:52:56 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-12-05 17:56:41 -0500

dbxaps gravatar image

Check you have openvswitch installed:

rpm -qa | grep openvswitch

and the correct kernel loaded:

# lsmod | grep openvswitch
edit flag offensive delete link more

Comments

@smafulli, That is my avatar , but it belongs to different e-mail address @hotmail.com with different user name. Here I am registered with another e-mail dbaxps@gmail.com . Please fix this mistake. I don't have privileges to do it.

dbaxps gravatar imagedbaxps ( 2014-12-06 00:05:38 -0500 )edit
0

answered 2014-12-06 00:07:10 -0500

dbaxps gravatar image

Check you have openvswitch installed:

rpm -qa | grep openvswitch

and the correct kernel loaded:

# lsmod | grep openvswitch
edit flag offensive delete link more
0

answered 2014-12-05 17:59:28 -0500

smaffulli gravatar image

Check that you have all openvswitch packages installed

# rpm -qa | grep openvswitch

and that the proper kernel module loaded:

# lsmod | grep openvswitch
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-04 03:27:08 -0500

Seen: 1,207 times

Last updated: Dec 06 '14