Ask Your Question
0

Restricting external DHCP

asked 2013-09-27 15:55:47 -0600

marcantonio gravatar image

I just brought up a new OpenStack install. Our network has a DHCP server that I do _not_ want to use with this setup. When I boot an image it grabs a DHCP address from the existing server and not from the controller. Is there a way tell OpenStack (nova?) to only use it's own DHCP server?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
-1

answered 2013-09-30 08:38:05 -0600

marcantonio gravatar image

I finally figured this out, and it turns out that I was barking up the wrong tree. The external DHCP address I was getting was only there because the OpenStack DHCP server was not responding. I found the answer here: https://github.com/mseknibilel/OpenStack-Folsom-Install-guide/issues/14 .

Note that it was a bit more than this! I already had the iptables rule applied that the issue mentions. However, it was applied to virtbr0. I added another rule for all interfaces and that fixed my problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-09-27 15:55:47 -0600

Seen: 295 times

Last updated: Sep 30 '13