Ask Your Question
1

error http 404

asked 2014-12-03 10:18:22 -0500

AlonFre gravatar image

updated 2014-12-03 11:31:54 -0500

mpetason gravatar image

In the openstack installetion manual ( http://docs.openstack.org/juno/instal... ) in task #4- verify operation we couldnt upload the image to the image service. The image is in the directory as written butt we keep getting an error - http 404 that the resource couldn't be found.. What can we do? Thanks for your help

Update:

p.s the output of what you suggested in the first place is this:

+----------------------------------+-----------+-----------------------------+-----------------------------+------------------------------+----------------------------------+ | id | region | publicurl | internalurl | adminurl | service_id | +----------------------------------+-----------+-----------------------------+-----------------------------+------------------------------+----------------------------------+ | 265e1e8e75d442ba95446cb1ce4d3c40 | regionOne | http://controller:5000/v2.0 | http://controller:5000/v2.0 | http://controller:35357/v2.0 | 811152742274424b95ecf186caebb4da || c2e661416f7044a19e6618ac945a5b05 | regionOne | http://controller:9292 | http://controller:9292 | http://controller:9292 | cf92d2d16d1c4cca9c4d1bd6a751cae2 | +----------------------------------+-----------+-----------------------------+-----------------------------+------------------------------+----------------------------------+

root@ubuntuServer2:/# keystone service-list WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored).

+----------------------------------+----------+----------+-------------------------+ | id | name | type | description | +----------------------------------+----------+----------+-------------------------+ | cf92d2d16d1c4cca9c4d1bd6a751cae2 | glance | image | OpenStack Image Service | | 811152742274424b95ecf186caebb4da | keystone | identity | OpenStack Identity | +----------------------------------+----------+----------+-------------------------+

root@ubuntuServer2:/# service glance-registry status glance-registry start/running, process 24157 root@ubuntuServer2:/# service glance-api status glance-api start/running, process 24174

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-12-03 10:39:12 -0500

mpetason gravatar image

You may want to go back to install and configure. Verify that you have setup the keystone endpoint:

keystone endpoint-list

You should see a few different endpoints. You can match up the Glance endpoint by matching the Service ID to the Service ID in the Endpoints:

keystone service-list

Once you have figured out if the Glance endpoint has been configured you need to verify that the service is running:

# service glance-registry status
# service glance-api status

If neither are running then you need to start them. If both are running and you are still getting errors then you could look at the error logs in:

# /var/log/glance

Otherwise you may want to look over the steps on the previous page and make sure that you didn't miss anything:

http://docs.openstack.org/juno/instal...

edit flag offensive delete link more

Comments

First of all thank you for your time. We did everything you said and it all looked o.k so we returned to the install and configure page. in phase 3.a when we are asked to - create the glance user - the common ERROR http 404 occures. do you know why that is?

AlonFre gravatar imageAlonFre ( 2014-12-03 11:22:40 -0500 )edit
1

Can you post the same command you used when you got the error but add in --debug. So it would look something like:

glance --debug image-list

Add that as an update to your original post.

mpetason gravatar imagempetason ( 2014-12-03 11:34:09 -0500 )edit

thanks for your help. we managed to fix the problem, in the configuration file: "keystone_authtoken" we entered: auth_uri = http://controller:5000/v2 instead of: auth_uri = http://controller:5000/v2.0

AlonFre gravatar imageAlonFre ( 2014-12-10 03:03:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-12-03 10:18:22 -0500

Seen: 953 times

Last updated: Dec 03 '14