Ask Your Question
1

Cannot provision gre network [closed]

asked 2014-12-03 05:37:49 -0500

updated 2014-12-03 06:24:56 -0500

I have just performed a 'yum update' on my controller (combined network node) and now Neutron <> openvswitch are not functioning. More specifically the 'neutron-openvswitch-agent' complains about not being able to provision the grey tunnels.

System: Centos 6.5 Openstack: Ice House 2014.1.3-4 Neutron packages : openstack-neutron-openvswitch-2014.1.3-4.el6.noarch openstack-neutron-ml2-2014.1.3-4.el6.noarch openstack-neutron-2014.1.3-4.el6.noarch OVS version 2.1.3 (previous was 1.11.0 before yum update)

Observations:

  1. patch port missing in br-int to patch=tun
  2. cannot provision gre tunnel messages in log
  3. No obvious errors/warnings in neutron 'server.log'

Here is the openvswitch-agent.log

2014-12-03 05:25:37.253 18206 INFO neutron.common.config [-] Logging enabled!
2014-12-03 05:25:37.674 18206 INFO neutron.openstack.common.rpc.impl_qpid [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Connected to AMQP server on controller:5672
2014-12-03 05:25:37.700 18206 INFO neutron.openstack.common.rpc.impl_qpid [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Connected to AMQP server on controller:5672
2014-12-03 05:25:37.874 18206 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Adding br-ex to list of bridges.
2014-12-03 05:25:37.874 18206 WARNING neutron.agent.securitygroups_rpc [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Driver configuration doesn't match with enable_security_group
2014-12-03 05:25:37.875 18206 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Agent initialized successfully, now running... 
2014-12-03 05:25:37.878 18206 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Agent out of sync with plugin!
2014-12-03 05:25:38.179 18206 INFO neutron.agent.securitygroups_rpc [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Preparing filters for devices set([u'436d846e-d5be-4328-952e-2866b2214c16', u'6fc26ebb-413f-4db3-920a-c35537ced71c', u'60dcbe7b-c1cf-44c3-b14f-5d63ddfb6aa8', u'b33d35e0-a14e-46a9-81ba-395a97c9c40e', u'eb0e4eb8-80c9-4549-bbbb-009c82d66ee4', u'515b009d-c71a-4aee-ad1f-6018bf6a4569', u'8e088556-c68c-4106-9651-a7b6e7fff419', u'0ba331e7-c905-46e7-a90d-473cf32bff63', u'5d193a7e-32ef-4bca-b525-960bdf005fac', u'a125dac3-17ef-4def-8916-211d94c8ea8f', u'0860a00f-d394-4487-9f2b-3f7e543b68d3', u'0a7d79c7-a560-4887-87ee-4b38b7b896c4', u'8be8ea15-77d1-4917-a180-56d2cfdd7f06', u'ee5b7768-562a-4908-81e1-996c2513d4bc', u'e7d3991b-8411-45ad-afc7-efcacafc46c8', u'4ade90bc-6c64-4001-8ce8-e87d2ac3effa'])
2014-12-03 05:25:38.183 18206 INFO neutron.openstack.common.rpc.impl_qpid [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Connected to AMQP server on controller:5672
2014-12-03 05:25:40.515 18206 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Port 60dcbe7b-c1cf-44c3-b14f-5d63ddfb6aa8 updated. Details: {u'admin_state_up': True, u'network_id': u'6d096a21-5928-40bc-9e34-be8c485f69d0', u'segmentation_id': 6, u'physical_network': None, u'device': u'60dcbe7b-c1cf-44c3-b14f-5d63ddfb6aa8', u'port_id': u'60dcbe7b-c1cf-44c3-b14f-5d63ddfb6aa8', u'network_type': u'gre'}
2014-12-03 05:25:40.515 18206 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Assigning 1 as local vlan for net-id=6d096a21-5928-40bc-9e34-be8c485f69d0
2014-12-03 05:25:40.515 18206 ERROR neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Cannot provision gre network for net-id=6d096a21-5928-40bc-9e34-be8c485f69d0 - tunneling disabled
2014-12-03 05:25:40.676 18206 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Configuration for device 60dcbe7b-c1cf-44c3-b14f-5d63ddfb6aa8 completed.
2014-12-03 05:25:40.798 18206 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-fcb63f5c-4abc-4c65-ac2b-1b4234169427 None] Port 8e088556-c68c-4106-9651-a7b6e7fff419 updated. Details: {u'admin_state_up': True, u'network_id': u'5165684e-c94f-4bd0-b9f3-784a9d942049', u'segmentation_id': 8, u'physical_network': None, u'device': u'8e088556-c68c-4106-9651-a7b6e7fff419', u'port_id': u'8e088556-c68c-4106-9651-a7b6e7fff419', u'network_type': u'gre'}

I'm looking for guidance on resolving this. Log files are giving up very few clues, googling, forums and ask haven't revealed much if anything...

Thanks

[UPDATE]

PLUGIN.INI (->plugins/ml2/ml2_conf.ini)

cat /etc/neutron/plugin.ini | grep -v ^$ | grep -v ^#
[ml2]
type_drivers ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by AndyHardwick
close date 2014-12-03 08:05:47.584717

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-12-03 06:01:19 -0500

dbaxps gravatar image

updated 2014-12-03 06:18:47 -0500

On Network Node under /etc/neutron have 2 files for ML2 plugin and OVS agent :-

lrwxrwxrwx. 1 root root       37 Sep 30 18:41 ml2_conf.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
lrwxrwxrwx. 1 root root       55 Sep 30 18:40 plugin.ini -> /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini

Make them absolutely identical :

[root@icehouse1 neutron(keystone_admin)]# cat ml2_conf.ini
[ml2]
type_drivers = gre
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True
[ovs]
local_ip = 192.168.0.127
[agent]
tunnel_types = gre
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf

[root@icehouse1 neutron(keystone_admin)]# cat plugin.ini
[ml2]
type_drivers = gre
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True
[ovs]
local_ip = 192.168.0.127
[agent]
tunnel_types = gre
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf

Restart Neutron services. Please, also UPDATE original question with ovs-vsctl show after reconfiguration.

edit flag offensive delete link more

Comments

the plugin.ini symlink points to ml2_conf.ini and the 'plugins/openvswitch/ovs_neutron_plugin.ini' is empty.

lrwxrwxrwx 1 root root       24 Sep 15 18:04 plugin.ini -> plugins/ml2/ml2_conf.ini

This setup work fine on IceHouse 2014.1.2-1

AndyHardwick gravatar imageAndyHardwick ( 2014-12-03 06:28:32 -0500 )edit

UPDATE info looks OK for me. What's going on right now ? Problems with neutron-openvswitch-agent still persist or got fixed ?

dbaxps gravatar imagedbaxps ( 2014-12-03 06:39:49 -0500 )edit

Tunneling is now working.. Thanks, quick and great answer.... either I missed the plugin config and was just lucky this has been running for such a long time or config style changed..

Outbound routing isn't but looking at that now..

AndyHardwick gravatar imageAndyHardwick ( 2014-12-03 06:43:51 -0500 )edit

If you have one external net, then having br-ex && br-ex:0 seems strange to me. Usually br-ex has eth(X) as port and all qg-* interfaces attached for outbound routing.

dbaxps gravatar imagedbaxps ( 2014-12-03 06:59:47 -0500 )edit

That shouldn't affect things. I removed it and the result was the same, no forwarding.

I have just spent some time looking at the iptables rules and it seems that something is broken with fwaas on my setup also now. I disabled fwaas in neutron and now I can forward.

Thanks for the help.

AndyHardwick gravatar imageAndyHardwick ( 2014-12-03 08:02:27 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-12-03 05:37:49 -0500

Seen: 1,801 times

Last updated: Dec 03 '14