Ask Your Question
1

not able to ssh into vm in icehouse [closed]

asked 2014-12-03 00:29:52 -0500

amitabh sinha gravatar image

updated 2014-12-03 05:07:15 -0500

I am having icehouse multi node (controller network compute ) setup on ubuntu 14.04 I have launched three instances with cirros ,fedoara and ubutnu .I am able to ping all instances but when i am trying to do ssh using
root@controller:~# ssh cirros@192.168.1.104 it is throwing an error {Read from socket failed: Invalid argument}

I have tried with telnet also. for ubuntu which is having 192.168.1.105

telnet 192.168.1.105 22 Trying 192.168.1.105... Connected to 192.168.1.105. SSH-2.0-OpenSSH_6.6.1p1 Ubuntu-2ubuntu2

security group rule efault

    ALLOW IPv6 from default
    ALLOW IPv4 icmp from 0.0.0.0/0
    ALLOW IPv4 22/tcp from 0.0.0.0/0
    ALLOW IPv4 to 0.0.0.0/0
    ALLOW IPv6 to ::/0
    ALLOW IPv4 from default

Connection closed by foreign host. please suggest me what should I do

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by amitabh sinha
close date 2015-03-11 00:52:12.902503

Comments

could you turn on the verbose mode and paste the logs here like this:

ssh -vv cirros@192.168.1.104
9lives gravatar image9lives ( 2014-12-03 05:28:05 -0500 )edit

can you please suggest me !In which file i ahve to set verbose as true.

amitabh sinha gravatar imageamitabh sinha ( 2014-12-04 05:29:09 -0500 )edit

what i mean is that add -vv in ssh command to turn on the verbose mode when ssh to the instance. Just paste the output of following command

ssh -vv cirros@192.168.1.104
9lives gravatar image9lives ( 2014-12-06 07:09:57 -0500 )edit

OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for * debug2: ssh_connect: needpriv 0 debug1: Connecting to 192.168.1.104 [192.168.1.104] port 22. debug1: Connection established. debug1: permanently

amitabh sinha gravatar imageamitabh sinha ( 2014-12-09 22:41:01 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-12-10 02:27:28 -0500

ahmed.myiweb gravatar image

Hi,

probably this links can help you http://guide.ubuntu-fr.org/server/openssh-server.html (http://guide.ubuntu-fr.org/server/ope...)

edit flag offensive delete link more
2

answered 2014-12-03 05:43:52 -0500

dbaxps gravatar image

First create an ssh keypair for your tenant :

# source keystonerc_demo
[root@juno1 ~(keystone_demo)]# nova keypair-add oskey1 > oskey1.priv
[root@juno1 ~(keystone_demo)]# chmod 600 oskey1.priv

Launch CirrOS instance :

[root@juno1 ~(keystone_demo)]#  nova boot --flavor 2 --key_name oskey1 --image \
   glance-image-cirros-id   cirr-guest1

Assign floating IP to cirr-guest1 (say 192.168.1.157) and run :

$ ssh -i oskey1.priv cirros@192.168.1.157
edit flag offensive delete link more

Comments

I have generated a key pair and while launching instances i am selecting key pair. and accessing vm like ssh -i key.pem ubuntu@192.168.1.105 . but it ssh is not happening.

amitabh sinha gravatar imageamitabh sinha ( 2014-12-09 03:09:54 -0500 )edit

when I am running on network node root@network:~# service dnsmasq restart i am getting this error. * Restarting DNS forwarder and DHCP server dnsmasq
dnsmasq: failed to create listening socket for 192.168.1.2: Address already in use

amitabh sinha gravatar imageamitabh sinha ( 2014-12-09 03:14:07 -0500 )edit
0

answered 2014-12-09 22:43:13 -0500

amitabh sinha gravatar image

updated 2015-03-11 00:49:53 -0500

HI ALL

if you are getting this debug message when you trying to do ssh in one of the vm using ssh i key.pem ubuntu@ip

debug1: sending SSH2_MSG_KEX_ECDH_INIT debug1: expecting SSH2_MSG_KEX_ECDH_REPLY Connection closed by 192.168.1.122

Then you better set your MTU TO 1400 . soln:- using sudo ip link set eth0 mtu 1400.

IT WORKED FOR ME!!

edit flag offensive delete link more

Comments

atlast I got ! Read from socket failed: Connection timed out

amitabh sinha gravatar imageamitabh sinha ( 2014-12-09 23:00:03 -0500 )edit

ok, we might need more ssh login log, please update the above ssh log using the following command

ssh -vvv  cirros@192.168.1.104

and we will take a close look.

UPDATE : you might probably hit this bug https://bugs.debian.org/cgi-bin/bugre...

9lives gravatar image9lives ( 2014-12-10 07:59:40 -0500 )edit

I got the same response!

amitabh sinha gravatar imageamitabh sinha ( 2014-12-22 02:10:40 -0500 )edit

ok, if you hit the above bug, did you try the mentioned workaround?

9lives gravatar image9lives ( 2014-12-22 03:07:20 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-03 00:29:52 -0500

Seen: 1,664 times

Last updated: Mar 11 '15