Ask Your Question
0

keystone returning http instead of https [closed]

asked 2014-12-02 15:56:42 -0500

bmhkb4 gravatar image

I recently configured heat on my Icehouse openstack cluster. When I use the heat client to connect, I'm redirected to http even though the keystone endpoint is https. What is going on?

Environment file

cat openrc.sh
export OS_USERNAME=openstackadmin
export OS_PASSWORD=*removed*
export OS_TENANT_NAME=admin
export OS_AUTH_URL=https://keystone.openstack.mycompany.com:35357/v2.0
export OS_CACERT=/etc/ssl/certs/keystone_ca.crt

Endpoints

| 48d6706109374c429a8911d5eb0e5ac1 | regionOne |     https://keystone.openstack.garmin.com:5000/v2.0      |     https://keystone.openstack.garmin.com:5000/v2.0      |     https://keystone.openstack.garmin.com:35357/v2.0     | e7abad23f9254f93a805de7dbef8474e |

Heat command output

heat -d stack-list
DEBUG (session) REQ: curl -i -X GET https://keystone.openstack.mycompany.com:35357/v2.0 -H "Accept: application/json" -H "User-Agent: python-keystoneclient"
DEBUG (session) RESP: [200] {'date': 'Tue, 02 Dec 2014 21:53:15 GMT', 'content-type': 'application/json', 'content-length': '633', 'vary': 'X-Auth-Token'}
RESP BODY: {"version": {"status": "stable", "updated": "2014-04-17T00:00:00Z", "media-types": [{"base": "application/json", "type": "application/vnd.openstack.identity-v2.0+json"}, {"base": "application/xml", "type": "application/vnd.openstack.identity-v2.0+xml"}], "id": "v2.0", "links": [{"href": "http://keystone.openstack.mycompany.com:35357/v2.0/", "rel": "self"}, {"href": "http://docs.openstack.org/api/openstack-identity-service/2.0/content/", "type": "text/html", "rel": "describedby"}, {"href": "http://docs.openstack.org/api/openstack-identity-service/2.0/identity-dev-guide-2.0.pdf", "type": "application/pdf", "rel": "describedby"}]}}

DEBUG (session) REQ: curl -i -X POST http://keystone.openstack.mycompany.com:35357/v2.0//tokens -H "Content-Type: application/json" -H "Accept: application/json" -H "User-Agent: python-keystoneclient" -d '{"auth": {"tenantName": "admin", "passwordCredentials": {"username": "openstackadmin", "password": "removed"}}}'

And it hangs there. Any thoughts?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by bmhkb4
close date 2014-12-03 11:06:22.489417

Comments

Verify the endpoints used in the heat configuration files under the keystone auth section. You may have entered in http instead of https as the method to use.

mpetason gravatar imagempetason ( 2014-12-02 16:01:40 -0500 )edit

heat.conf is correct. It ended up being a bug in keystone. Updating it fixed it.

bmhkb4 gravatar imagebmhkb4 ( 2014-12-03 11:03:42 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-12-02 17:17:24 -0500

updated 2014-12-02 17:17:47 -0500

Do you have any of the following config option set in keystone.conf? If so remove them and restart keystone

public_endpoint=
admin_endpoint=
edit flag offensive delete link more

Comments

Yes, this was part of the fix. Thanks.

bmhkb4 gravatar imagebmhkb4 ( 2014-12-03 11:05:01 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-02 15:55:36 -0500

Seen: 678 times

Last updated: Dec 02 '14