installation juno keystone can't authenticate [closed]

asked 2014-12-02 08:27:25 -0600

vari gravatar image

Hello, I try to install OpenStack Juno on Ubuntu 14.04 and right at the begining I have a problem. I configured the keystone.conf file as it is descripet and set my OS_SERVICE_TOKEN and the OS_SERVICE_ENDPOINT but when I try to create a new tenant I get an error:

root@Usedom:/etc/keystone# export OS_SERVICE_ENDPOINT=http://controller:35357/v2.0
root@Usedom:/etc/keystone# keystone tenant-create --name admin --description "Admin Tenant"
WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored).
An unexpected error prevented the server from fulfilling your request. (HTTP 500)

I have no idea what I did wrong, can anybody help? (network information: I didn't set up a klass A private network, cause the server are all in the same subnet and each have a static IP, but on this point in the installation it shouldn't have an effecct anyway)

edit retag flag offensive reopen merge delete

Closed for the following reason question is off-topic or not relevant by vari
close date 2014-12-15 09:56:39.749188

Comments

Please add keystone.log details

Haneef Ali gravatar imageHaneef Ali ( 2014-12-02 11:13:19 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-12-02 13:21:09 -0600

updated 2014-12-02 14:41:53 -0600

To be authenticated on the keystone, two authentication methods are available:

  • Using admin_token
  • Using User/Pass combination

Example of admin_token keystone authentication method:

export OS_SERVICE_ENDPOINT = http://keystone-server:5000/v2.0
export OS_SERVICE_TOKEN = Admin_token

Example of user/pass keystone authentication method:

export OS_AUTH_URL = http://keystone-server:5000/v2.0
export OS_TENANT_NAME = tenant
export OS_REGION_NAME = region
export OS_USERNAME = username
export OS_PASSWORD = passwd

You have to select only one of the above methods, not both at the same time.

It seems like you configured your keystone and set environment variables to use both of these methods at the same time.

From your shell commands, it seems you want to use method #1. So, after set the OS_SERVICE_ENDPOINT variable, you need to set admin token using:

export OS_SERVICE_TOKEN = Admin_token

Replace your admin token value instead of Admin_token in this command.

Hope to be useful.

edit flag offensive delete link more

Comments

Sorry, but I did set the Admin_Token, I only missed to copy this line too. I searched a bit more and it seems that despite keystone is running, it can't connect to it. After rebooting and starting keystone again, the http code changed to 503, unable to establish connection to the server

vari gravatar imagevari ( 2014-12-03 02:30:59 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-02 08:27:25 -0600

Seen: 428 times

Last updated: Dec 02 '14