Ask Your Question
0

Neutron: Router port connected to external network is showing status Down

asked 2014-12-02 01:57:40 -0600

Vivek gravatar image

updated 2014-12-02 02:59:42 -0600

dbaxps gravatar image

I have a external network 192.168.182.0/24 and I have unlinked the router to this external network using router-gateway-set command. However I see that router port (Type External Gateway) connected to this external network is showing down.

I even started a instance and associated the floating IP from this external pool to that VMs private IP address hoping that ,this may actually bring the port UP but still the problem persists. I am relatively new user of Openstack not played around all the neutron options. Am I missing any other configuration or is there something wrong with my installation ?

I have a multi-node setup of control,compute and network nodes.

 root@controller:/home/regress# neutron router-port-list router1 -c status -c id                                                               +--------+--------------------------------------+
    | status | id                                   |
    +--------+--------------------------------------+
    | ACTIVE | 5745b8d9-8187-4330-8fbe-c308252509ba |
    | DOWN   | bb767dcf-d337-4ea5-8b68-b8a6a0496c90 |
    +--------+--------------------------------------+
    root@controller:/home/regress# 
    root@controller:/home/regress# 
    root@controller:/home/regress# 
    root@controller:/home/regress# 
    root@controller:/home/regress# 
    root@controller:/home/regress# 

 root@controller:/home/regress# neutron port-show bb767dcf-d337-4ea5-8b68-b8a6a0496c90                                                         +-----------------------+--------------------------------------------------------------------------------------+
    | Field                 | Value                                                                                |
    +-----------------------+--------------------------------------------------------------------------------------+
    | admin_state_up        | True                                                                                 |
    | allowed_address_pairs |                                                                                      |
    | binding:host_id       | network                                                                              |
    | binding:profile       | {}                                                                                   |
    | binding:vif_details   | {"port_filter": true, "ovs_hybrid_plug": true}                                       |
    | binding:vif_type      | ovs                                                                                  |
    | binding:vnic_type     | normal                                                                               |
    | device_id             | 15273fc6-5519-4a34-b207-d28ea7794143                                                 |
    | device_owner          | network:router_gateway                                                               |
    | extra_dhcp_opts       |                                                                                      |
    | fixed_ips             | {"subnet_id": "b497969c-d1e1-482a-b678-0b5eecbad2ba", "ip_address": "192.168.182.2"} |
    | id                    | bb767dcf-d337-4ea5-8b68-b8a6a0496c90                                                 |
    | mac_address           | fa:16:3e:a1:47:c3                                                                    |
    | name                  |                                                                                      |
    | network_id            | 18ee9a02-ef46-4c23-a46d-6a5514e8c891                                                 |
    | security_groups       |                                                                                      |
    | status                | DOWN                                                                                 |
    | tenant_id             |                                                                                      |
    +-----------------------+--------------------------------------------------------------------------------------+
    root@controller:/home/regress#
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-02 03:06:29 -0600

dbaxps gravatar image

That is normal . It won't affect your system. Report from working Juno Cluster:

[root@juno1 ~(keystone_admin)]# neutron router-port-list router4  -c status -c id
+--------+--------------------------------------+
| status | id                                   |
+--------+--------------------------------------+
| DOWN   | 7b037650-10e3-4818-8ff2-4fbd914679d9 |
| ACTIVE | a494fcc8-e581-4f98-9389-d1031c7785c9 |
+--------+--------------------------------------+

Check port:

[root@juno1 ~(keystone_admin)]# neutron port-show 7b037650-10e3-4818-8ff2-4fbd914679d9 | grep status
| status                | DOWN                                                                                 |
edit flag offensive delete link more

Comments

Im following OpenStack Juno installation guide and Im having the exact same problem. I dont have ping to the gateway. Any help ?

babak gravatar imagebabak ( 2015-04-17 09:53:07 -0600 )edit

I am also facing the same issue. I can reach my openstack host machine from inside my instance, however I cannot reach the gateway of my openstack host. I'm using OpenStack RDO all-in-one setup. Could anyone provide any solution?

sajjanbh gravatar imagesajjanbh ( 2015-11-18 00:43:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-12-02 01:54:38 -0600

Seen: 4,933 times

Last updated: Dec 02 '14