Error while installing cinder-volume [closed]

asked 2013-09-27 05:01:04 -0500

sngirame gravatar image

I am following the guide to install openstack controller node http://docs.openstack.org/grizzly/basic-install/apt/content/basic-install_controller.html

I am getting following error while trying to install cinder-volume and the machine is x86 machine.

tgt : Depends: librdmacm1 (>= 1.0.15) but 1.0.14.1-2 is installed.

When I try to download and install librdmacm1 from http://packages.ubuntu.com/quantal/i386/librdmacm1/download OR http://packages.ubuntu.com/raring/i386/librdmacm1/download

I am getting an error "is not a debian format archive" How to Fix this?

-- dpkg -i librdmacm1_1.0.15-1_i386.deb

dpkg-deb: error: `librdmacm1_1.0.15-1_i386.deb' is not a debian format archive dpkg: error processing librdmacm1_1.0.15-1_i386.deb (--install): subprocess dpkg-deb --control returned error exit status 2 Errors were encountered while processing: librdmacm1_1.0.15-1_i386.deb

--dpkg -i librdmacm1_1.0.16-1_i386.deb

dpkg-deb: error: `librdmacm1_1.0.16-1_i386.deb' is not a debian format archive dpkg: error processing librdmacm1_1.0.16-1_i386.deb (--install): subprocess dpkg-deb --control returned error exit status 2 Errors were encountered while processing: librdmacm1_1.0.16-1_i386.deb

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-09-22 14:06:39.709656

Comments

Hi, I am also facing the same problem.. are you able to fix this issue ?

shalmali gravatar imageshalmali ( 2013-09-30 00:52:35 -0500 )edit

Please see if apt get update & rebooting machine resolves the issue.

sngirame gravatar imagesngirame ( 2013-10-15 00:18:31 -0500 )edit

Closing: This question relates to a version of OpenStack which has been marked End Of Life - https://releases.openstack.org/ If you are still experiencing the problem with a more recent version of OpenStack, please open a new question. Thanks!

rbowen gravatar imagerbowen ( 2016-09-22 14:06:35 -0500 )edit