Ask Your Question
1

Midonet Midostack with DevStack

asked 2014-11-30 07:03:33 -0500

cloudssky gravatar image

I'm trying to install midostack on a VM running on OpenStack by following this guide:

https://github.com/midonet/midostack

but after running the install script, I'm getting:

./midonet_stack.sh:186:die

and in the log files I see it claims, that there is no local IP.

Any ideas?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-11-30 07:10:54 -0500

cloudssky gravatar image

updated 2014-11-30 08:05:19 -0500

Had to set:

export HOST_IP=10.0.0.18

and now it seems to go through the installation.

After the initial setup, I could log into the dashboard, but after a reboot now I'm getting:

    ConnectionError at /admin/
HTTPConnectionPool(host='10.0.0.18', port=8774): Max retries exceeded with url: /v2/82119ede028d41618c80c53d09757f4f/extensions (Caused by <class 'socket.error'>: [Errno 111] Connection refused)
Request Method: GET
Request URL:    http://10.0.0.18/admin/
Django Version: 1.6.8
Exception Type: ConnectionError
Exception Value:    
HTTPConnectionPool(host='10.0.0.18', port=8774): Max retries exceeded with url: /v2/82119ede028d41618c80c53d09757f4f/extensions (Caused by <class 'socket.error'>: [Errno 111] Connection refused)
Exception Location: /usr/lib/python2.7/dist-packages/requests/adapters.py in send, line 378
Python Executable:  /usr/bin/python
Python Version: 2.7.6
Python Path:    
['/opt/stack/horizon/openstack_dashboard/wsgi/../..',
 '/opt/stack/midonet/python-neutron-plugin-midonet',
 '/opt/stack/keystone',
 '/opt/stack/glance',
 '/opt/stack/cinder',
 '/opt/stack/neutron',
 '/opt/stack/nova',
 '/opt/stack/horizon',
 '/opt/stack/heat',
 '/opt/stack/tempest',
 '/opt/stack/midonet/python-midonetclient/src',
 '/usr/lib/python2.7',
 '/usr/lib/python2.7/plat-x86_64-linux-gnu',
 '/usr/lib/python2.7/lib-tk',
 '/usr/lib/python2.7/lib-old',
 '/usr/lib/python2.7/lib-dynload',
 '/usr/local/lib/python2.7/dist-packages',
 '/usr/lib/python2.7/dist-packages',
 '/usr/lib/pymodules/python2.7',
 '/opt/stack/horizon/openstack_dashboard']
Server time:    Sun, 30 Nov 2014 14:00:21 +0000
edit flag offensive delete link more
1

answered 2014-12-01 18:17:37 -0500

Tim gravatar image

@cloudssky That correct, if the ip can't be directly determined by ifconfig, then you need to specify it in an env variable. The second issue you're having looks like the classic Horizon allowed_hosts issue. You'll need to specify a whitelist of addresses on which Horizon can be accessed in it's config.

I believe it should be at /etc/openstack-dashboard/local.js or something along these lines.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-30 07:03:33 -0500

Seen: 209 times

Last updated: Dec 01 '14