Ceilometer api in stop/waiting state

asked 2014-11-29 23:10:00 -0500

pradhebaa gravatar image

I deployed ceilometer on controller and compute node in ubuntu when i run $ceilometer-meter list ,I get the following error. "HTTPConnectionPool(host='controller', port=8777): Max retries exceeded with url: /v2/meters (Caused by <class 'connectionrefusederror'="">: [Errno 111] Connection refused)"

When i checked the ceilometer-api status, its in the stop/waiting state. In the log I could find,TypeError: unsupported type for timedelta seconds component: str.

when i give this command, netstat -lntp | grep 8777 ,it shows nothing.which means its not listening on this port.

I installed mongodb and its running succesfully. service mongodb status mongodb start/running, process 1493

Connection with the AMQP server on controller node (port 5672) is connected. I dono why ceilometer-api server fails.

I tried everything mentioned in the discussion regarding the same problem.but nothing helped me! Please help me to solve this issue! Any help would be appreciated!

Attachments : 1.ceilometer.conf - http://pastebin.ubuntu.com/9309170/ 2.ceilometer-api.log -http://pastebin.ubuntu.com/9309220/

edit retag flag offensive close merge delete

Comments

See if you can attach them again. Usually this happens when you have issues with the configuration file. Neutron errors out when configuration files are incorrect in the same manner : max retries exceeded.

mpetason gravatar imagempetason ( 2014-12-02 16:47:25 -0500 )edit

This a known issue and is addressed easily without having to edit any source code.

See comments in the bug:

https://bugs.launchpad.net/ceilometer...

sfcloudman gravatar imagesfcloudman ( 2014-12-31 01:43:00 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-31 00:42:18 -0500

Harsh Mehta gravatar image

Hi I have the same problem. And i found from my ceilometer-api log file that in /usr/local/lib/python2.7/dist-packages/keystoneclient/middleware/auth_token.py there is a Type error for timedelta . Which is in this case is a string. But actually it should be an integer. So i simply go to that file and go to this call at line 596 and just chane the call as bellow.

Preveiouse Insturction : *self.token_revocation_list_cache_timeout = datetime.timedelta( seconds=self._conf_get('revocation_cache_time'))*

Updated Instruction: self.token_revocation_list_cache_timeout = datetime.timedelta(10)

Here timedelta need an integer value. So here u can provide any integer value.Here i provide 10 . It is jaust a time in seconds.

I hope it will help others.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-29 23:10:00 -0500

Seen: 844 times

Last updated: Dec 31 '14