Ask Your Question
5

No Ports Available when trying to associate a floating IP

asked 2014-11-29 09:43:16 -0600

Anonymouslemming gravatar image

I've deployed Openstack using RedHat's Packastack allinone option on Centos7. I then followed the instructions at https://openstack.redhat.com/Neutron_with_existing_external_network to use my existing external network.

Next, I created a private network for the admin project with a range of 192.168.13.0/24.

I then started up a guest in the admin project, and it was allocated an IP from this range (192.168.13.2). However, when I come to associate a floating IP with this guest so that I can access it internally, I am receiving a message saying "No Ports Available".

I am able to select an IP address from the pool that I setup when following the document above.

image description

Can anyone advise what I have to do in order to complete this setup and map floating IPs to my compute instances on the private network please ?

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
6

answered 2015-09-03 06:55:02 -0600

zioproto gravatar image

You need to create a router in your tenant. The router should have 1 interface in the private network you created and you should also set the gateway for the router in the external network.

After these steps you will be able to assign floating IPs to instances from the web interface.

edit flag offensive delete link more
2

answered 2015-09-17 07:45:52 -0600

pvinodp gravatar image

If you need to associate a floating ip to a instance then it needs to connect to router which has both public and private network. Look into your network topology and ad a router which connects your public and private subnet.

edit flag offensive delete link more
2

answered 2014-11-29 10:26:50 -0600

dbaxps gravatar image

updated 2014-11-29 10:33:18 -0600

Try to click (+), if it won't help test via CLI :

# source keystonerc_admin

[root@juno1 ~(keystone_admin)]# neutron floatingip-create public
Created a new floatingip:
+---------------------+--------------------------------------+
| Field               | Value                                |
+---------------------+--------------------------------------+
| fixed_ip_address    |                                      |
| floating_ip_address | 192.168.1.158                        |
| floating_network_id | 65cbd354-daae-41bb-9d3c-e58b1062be19 |
| id                  | 723242ca-61df-4d70-acf8-7678628b14f9 |
| port_id             |                                      |
| router_id           |                                      |
| status              | DOWN                                 |
| tenant_id           | 2561f253faca48399d0cc77886574e1d     |
+---------------------+--------------------------------------+

Then run

[root@juno1 ~(keystone_admin)]# neutron floatingip-list

Make sure created floating IP is there and run

[root@juno1 ~(keystone_admin)]# nova list

Your instance should come up with instance-id, name , status ACTIVE. Next command

 [root@juno1 ~(keystone_admin)]# neutron port-list --device-id   instance-id

should return you port-id to be assigned floating IP

[root@juno1 ~(keystone_admin)]#  neutron floatingip-associate  723242ca-61df-4d70-acf8-7678628b14f9 port-id
 [root@juno1 ~(keystone_admin)]#  neutron floatingip-show   723242ca-61df-4d70-acf8-7678628b14f9

Of course your floatingip-id ( in my case 723242ca-61df-4d70-acf8-7678628b14f9 ) would be different from mine.

edit flag offensive delete link more

Comments

Thanks for the pointers. When I run floatingip-associate <floatingid> <portid> I the following in my log External network abfdeb4f-9977-47fc-b3cd-dc0f8d7e1300 is not reachable from subnet 5660c355-f872-4d93-8571-3ce482dd899e. Therefore, cannot associate Port <id> with a Floating IP.

Anonymouslemming gravatar imageAnonymouslemming ( 2014-11-29 10:45:28 -0600 )edit

Recreate public network belongs tenant (project) services . Are you sure tenants credentials exported belong to admin ?

dbaxps gravatar imagedbaxps ( 2014-11-29 10:52:14 -0600 )edit

The advice in this answer pointed me to the following: https://ask.openstack.org/en/question/1980/how-to-configure-multiple-floating-ip-pools/. Having created a router with an interface in private, this works.

Anonymouslemming gravatar imageAnonymouslemming ( 2014-11-29 11:00:17 -0600 )edit

How do we get Horizon to work so that the ports show up in the drop down?

Jet gravatar imageJet ( 2015-03-23 16:09:35 -0600 )edit

Doesn't show up in horizon, any help?

themiddleman gravatar imagethemiddleman ( 2015-08-28 14:32:35 -0600 )edit
1

answered 2015-12-03 00:20:09 -0600

Amber gravatar image

I just met the same issue and fixed it as the following way. Check the setting of your router.( I assumed you already have the public network, the private network, and the routers.) log in as guest, in the project tab, open the Network dropdown menu and select the Rourter, click the Set Gateway button in the router row. In the External Network menu, choose public. click the set gateway button. still in the Router subtab, click the router, +Add interface. in the subnet menu, select your private network, click the add interface button. Verify that both networks are attached to the router. In the Network tab, choose the Network Topology. private and public should both connect to the router.

edit flag offensive delete link more

Comments

logging as guest disallows the request. What should i do now?

saadhud gravatar imagesaadhud ( 2016-03-07 07:01:50 -0600 )edit

thank you this works for me

cybercharly gravatar imagecybercharly ( 2017-08-15 13:05:43 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-11-29 09:43:16 -0600

Seen: 13,819 times

Last updated: Sep 17 '15