Instances are unable to receive ip from dhcp in Ice house openstack.

asked 2014-11-29 01:56:58 -0500

Manohar gravatar image

updated 2014-11-29 02:01:07 -0500

dbaxps gravatar image

I have created two node openstack cloud with controller and network in one node and compute on other node. Installed Centos6.5 and has used packstack to install openstack everything went well, initially instance use to get IP address later I modified from vxlan to gre in neutron configuration after that instance are not able to get ip and even before and after the instance is not reacheable from controller or compute. I don't know whether gre with ml2 plugin requires vlan information and more over even after changing from vxlan to gre in configuration after several restarts of nodes and services still it is showing as vxlan. Kindly help me on this.

[root@compute01 ~(keystone_admin)]# neutron agent-show 72339e80-d213-4104-8e73-f24be77b8bf0
+---------------------+------------------------------------------+
| Field               | Value                                    |
+---------------------+------------------------------------------+
| admin_state_up      | True                                     |
| agent_type          | Open vSwitch agent                       |
| alive               | False                                    |
| binary              | neutron-openvswitch-agent                |
| configurations      | {                                        |
|                     |      "tunnel_types": [                   |
|                     |           "vxlan"                        |
|                     |      ],                                  |
|                     |      "tunneling_ip": "147.128.148.156",  |
|                     |      "bridge_mappings": {},              |
|                     |      "l2_population": false,             |
|                     |      "devices": 2  
==========================================================================
[root@controller ~]# cat /etc/neutron/plugins/ml2/ml2_conf.ini |grep -i gre |grep -v "#"
type_drivers = gre
tenant_network_types = gre
[ml2_type_gre]
tunnel_type = gre
[root@controller ~]#
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-29 02:58:39 -0500

dbaxps gravatar image

View RDO Setup Two Real Node (Controller+Compute) IceHouse Neutron ML2&OVS&GRE Cluster on Fedora 20 . OVS misconfiguration takes place on your system.

On Controller :

[root@icehouse1 neutron(keystone_admin)]# ls -l
total 72
-rw-r--r--. 1 root root      193 Sep 30 17:08 api-paste.ini
-rw-r-----. 1 root neutron  3901 Sep 30 19:19 dhcp_agent.ini
-rw-r--r--. 1 root root       86 Sep 30 19:20 dnsmasq.conf
-rw-r-----. 1 root neutron   208 Sep 30 17:08 fwaas_driver.ini
-rw-r-----. 1 root neutron  3431 Sep 30 17:08 l3_agent.ini
-rw-r-----. 1 root neutron  1400 Aug  8 02:56 lbaas_agent.ini
-rw-r-----. 1 root neutron  1863 Sep 30 17:08 metadata_agent.ini
lrwxrwxrwx. 1 root root       37 Sep 30 18:41 ml2_conf.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
-rw-r-----. 1 root neutron 19187 Sep 30 17:08 neutron.conf
lrwxrwxrwx. 1 root root       55 Sep 30 18:40 plugin.ini -> /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
-rw-r--r--. 1 root root      211 Sep 30 17:30 plugin.out
drwxr-xr-x. 4 root root     4096 Sep 30 17:08 plugins
-rw-r-----. 1 root neutron  6148 Aug  8 02:56 policy.json
-rw-r--r--. 1 root root       79 Aug 11 15:27 release
-rw-r--r--. 1 root root     1216 Aug  8 02:56 rootwrap.conf

[root@icehouse1 neutron(keystone_admin)]# cat ml2_conf.ini
[ml2]
type_drivers = gre
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True
[ovs]
local_ip = 192.168.0.127
[agent]
tunnel_types = gre
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf

[root@icehouse1 neutron(keystone_admin)]# cat plugin.ini
[ml2]
type_drivers = gre
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True
[ovs]
local_ip = 192.168.0.127
[agent]
tunnel_types = gre
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-29 01:56:58 -0500

Seen: 680 times

Last updated: Nov 29 '14