Problem configuring RDO with existing network

asked 2014-11-28 14:39:58 -0600

Rafadotnechi gravatar image

updated 2014-11-28 14:45:13 -0600

dbaxps gravatar image

Hi, i did a installation of RDO icehouse 4 in a laptop running Fedora 20 and configured it to run within the local network based on this video, but i am unable to ssh the image as show in the video, i am getting a "No route to host error"

**This is what ovs-vcstl shows me:**<br>
  Bridge br-ex <br>
        Port "p5p1"<br>
            Interface "p5p1"<br>
        Port br-ex<br>
            Interface br-ex<br>
                type: internal<br>
    Bridge br-int<br>
        fail_mode: secure<br>
        Port "qvoa49a324c-de"<br>
            tag: 4<br>
            Interface "qvoa49a324c-de"<br>
        Port "tap90f34336-af"<br>
            tag: 5<br>
            Interface "tap90f34336-af"<br>
                type: internal<br>
        Port "qr-1b869f64-8f"<br>
            tag: 4<br>
            Interface "qr-1b869f64-8f"<br>
                type: internal<br>
        Port "tap6a4251b4-3c"<br>
            tag: 4<br>
            Interface "tap6a4251b4-3c"<br>
                type: internal<br>
        Port br-int<br>
            Interface br-int<br>
                type: internal<br>
        Port patch-tun<br>
            Interface patch-tun<br>
                type: patch<br>
                options: {peer=patch-int}<br>
    Bridge br-tun<br>
        Port patch-int<br>
            Interface patch-int<br>
                type: patch<br>
                options: {peer=patch-tun}<br>
        Port br-tun<br>
            Interface br-tun<br>
                type: internal<br>

This is my ifcfg-br-ex file:

DEVICE=br-ex<br>
OVSBOOTPROTO=dhcp<br>
OVSDHCPINTERFACES=p5p1<br>
NM_CONTROLLED=no<br>
ONBOOT=no<br>
TYPE=OVSBridge<br>
DEVICETYPE=ovs<br>

and this is my ifcfg-p5p1(the ethernet interface)

TYPE="OVSPort"<br>
DEVICE="p5p1"<br>
DEVICETYPE="ovs"<br>
OVS_BRIDGE="br-ex"<br>
ONBOOT="no"<br>
NM_CONTROLLED="no"<br>
NAME="p5p1"<br>
UUID="917622aa-924c-4879-9280-4cdd00b1ecab"<br>
HWADDR="54:04:A6:8E:F4:07"<br>

and this is what ifconfig shows me:

br-ex: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500<br>
        inet 192.168.1.143  netmask 255.255.255.0  broadcast 192.168.1.255<br>
        inet6 fd81:86c4:42fd:0:5604:a6ff:fe8e:f407  prefixlen 64  scopeid 0x0<global><br>
        inet6 fe80::5604:a6ff:fe8e:f407  prefixlen 64  scopeid 0x20<link><br>
        ether 54:04:a6:8e:f4:07  txqueuelen 0  (Ethernet)<br>
        RX packets 19581  bytes 22246234 (21.2 MiB)<br>
        RX errors 0  dropped 0  overruns 0  frame 0<br>
        TX packets 12938  bytes 1551514 (1.4 MiB)<br>
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0<br>

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536<br>
        inet 127.0.0.1  netmask 255.0.0.0<br>
        inet6 ::1  prefixlen 128  scopeid 0x10<host><br>
        loop  txqueuelen 0  (Local Loopback)<br>
        RX packets 148513  bytes 68455034 (65.2 MiB)<br>
        RX errors 0  dropped 0  overruns 0  frame 0<br>
        TX packets 148513  bytes 68455034 (65.2 MiB)<br>
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0<br>

p5p1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500<br>
        inet6 fe80::5604:a6ff:fe8e:f407  prefixlen 64  scopeid 0x20<link><br>
        ether 54:04:a6:8e:f4:07  txqueuelen 1000  (Ethernet)<br>
        RX packets 49410  bytes 62425472 (59.5 MiB)<br>
        RX errors 0  dropped 0  overruns 0  frame 0<br>
        TX packets 32306  bytes 3183795 (3.0 MiB)<br>
        TX errors 0  dropped 0 overruns 0  carrier 1  collisions 0<br>

qbra49a324c-de: flags=4163 ...
(more)
edit retag flag offensive close merge delete

Comments

When you ran packstack I believe it was bind to static IP. I would suggest you use this static IP and fix ifcfg-br-ex file (remove DHCP mode) . Please, post also file /etc/neutron/plugins/ml2/ml2_conf.ini. Source as root keystonerc_admin and run openstack-status.

dbaxps gravatar imagedbaxps ( 2014-11-28 14:57:45 -0600 )edit

Please, post as UPDATE1 to your question

1. fixed ifcfg-br-ex
2. /etc/neutron/plugins/ml2/ml2_conf.ini
3. openstack-status report

or upload somewhere as text files

dbaxps gravatar imagedbaxps ( 2014-11-28 15:00:06 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-12-01 12:47:53 -0600

Rafadotnechi gravatar image

Ok i have changed br-ex to get a static ip:

DEVICE=br-ex
OVSBOOTPROTO=static
IPADDR=192.168.1.143
GATEWAY=192.168.1.1
NETMASK=255.255.255.0
NM_CONTROLLED=no
ONBOOT=no
TYPE=OVSBridge
DEVICETYPE=ovs

and i have uninstalled RDO with the big hammer script and re-ran the installation,but still no route to host . This is my ml2_conf.ini after the re-installation:

[ml2]
# (ListOpt) List of network type driver entrypoints to be loaded from
# the neutron.ml2.type_drivers namespace.
#
# type_drivers = local,flat,vlan,gre,vxlan
type_drivers = vxlan
# Example: type_drivers = flat,vlan,gre,vxlan

# (ListOpt) Ordered list of network_types to allocate as tenant
# networks. The default value 'local' is useful for single-box testing
# but provides no connectivity between hosts.
#
# tenant_network_types = local
tenant_network_types = vxlan
# Example: tenant_network_types = vlan,gre,vxlan

# (ListOpt) Ordered list of networking mechanism driver entrypoints
# to be loaded from the neutron.ml2.mechanism_drivers namespace.
# mechanism_drivers =
mechanism_drivers =openvswitch
# Example: mechanism_drivers = openvswitch,mlnx
# Example: mechanism_drivers = arista
# Example: mechanism_drivers = cisco,logger
# Example: mechanism_drivers = openvswitch,brocade
# Example: mechanism_drivers = linuxbridge,brocade

[ml2_type_flat]
# (ListOpt) List of physical_network names with which flat networks
# can be created. Use * to allow flat networks with arbitrary
# physical_network names.
#
# flat_networks =
# Example:flat_networks = physnet1,physnet2
# Example:flat_networks = *

[ml2_type_vlan]
# (ListOpt) List of <physical_network>[:<vlan_min>:<vlan_max>] tuples
# specifying physical_network names usable for VLAN provider and
# tenant networks, as well as ranges of VLAN tags on each
# physical_network available for allocation as tenant networks.
#
# network_vlan_ranges =
# Example: network_vlan_ranges = physnet1:1000:2999,physnet2

[ml2_type_gre]
# (ListOpt) Comma-separated list of <tun_min>:<tun_max> tuples enumerating ranges of GRE tunnel IDs that are available for tenant network allocation
# tunnel_id_ranges =

[ml2_type_vxlan]
# (ListOpt) Comma-separated list of <vni_min>:<vni_max> tuples enumerating
# ranges of VXLAN VNI IDs that are available for tenant network allocation.
#
# vni_ranges =
vni_ranges =10:100

# (StrOpt) Multicast group for the VXLAN interface. When configured, will
# enable sending all broadcast traffic to this multicast group. When left
# unconfigured, will disable multicast VXLAN mode.
#
# vxlan_group =
vxlan_group =224.0.0.1
# Example: vxlan_group = 239.1.1.1

[securitygroup]
# Controls if neutron security group is enabled or not.
# It should be false when you use nova security group.
# enable_security_group = True
enable_security_group = True

Btw to run the installation of icehouse r4 i need to have NetworkManager enabled(if it`s disabled the script fails) , the first installation i did i had run with dhcp enabled on the NetworkManager, the reinstallation i ran with static ip on the manager, after the installation i disabled NetworkManager ofc.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-28 14:39:58 -0600

Seen: 574 times

Last updated: Dec 01 '14