Ask Your Question
0

Unable to open Elastic Search http api port 9200

asked 2014-11-27 01:01:29 -0600

Vishal gravatar image

Hi,

I just installed Elasticsearch and apache on openstack Ubuntu 12.04 machine.

I can access my apache on http://<publicip> but unable to access elasticsearch http endpoint on http://<publicip>:9200

Can someone please help?

I have already used following commands to open the ports:

sudo ufw allow 9200

sudo ufw allow 9300

sudo ufw allow 9400

sudo ufw allow 80

  • Vishal
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-02 16:23:50 -0600

mpetason gravatar image

Did you happen to setup your Security Groups in OpenStack to allow traffic on these ports? You'll want to verify the Security Group associated with the instance and make sure that it is allowing icmp/udp/tcp traffic to 9200, or allow all.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-27 01:01:29 -0600

Seen: 2,276 times

Last updated: Dec 02 '14