Ask Your Question
0

OpenStack juno packages for ubuntu 14.04 [closed]

asked 2014-11-25 00:55:21 -0500

yuecong1104 gravatar image

updated 2014-11-25 00:56:07 -0500

In the install guide for ubuntu 14.04, http://docs.openstack.org/juno/install-guide/install/apt/content/ch_basic_environment.html#basics-packages (http://docs.openstack.org/juno/instal...)

I have several questions which are not clarified int eh documentation.

  1. Do this package configuration necessary for all nodes, or it is only for controller node? At least, I think the following database and message server are just for controller node. So I am confused whether other nodes(compute and network) need the package repository configration as the documentation mentioned.

  2. "# add-apt-repository cloud-archive:juno" is buggy as mentioned in other threads. I am using add-apt-repository pap:ubuntu-cloud-archive/juno-staging as the workgroup. Is there any other good advice for this if I want to install juno for ubuntu 14.04?

Thanks,

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SamYaple
close date 2014-11-27 20:40:11.009680

2 answers

Sort by ยป oldest newest most voted
3

answered 2014-11-25 03:21:51 -0500

SamYaple gravatar image

updated 2014-11-25 03:22:27 -0500

  1. You must add the cloud-archive repo to all of your nodes running openstack packages. I would be safe and just and them to all nodes in your evironment servicing Openstack

  2. You must enable the trusty-updates repository. Then you can run the following commands and have them work properly.


# apt-get update && apt-get install -y software-properties-common
# add-apt-repository -y cloud-archive:juno
edit flag offensive delete link more

Comments

Thanks for the answer. It work now with adding "#apt-get install -y software-properties-common".

yuecong1104 gravatar imageyuecong1104 ( 2014-11-26 00:33:03 -0500 )edit

I will push an update to the docs for the appropriate package name

SamYaple gravatar imageSamYaple ( 2014-11-26 02:18:45 -0500 )edit

I added a pull request. Ill get some people to review it later today.

SamYaple gravatar imageSamYaple ( 2014-11-26 04:19:01 -0500 )edit
2

answered 2014-11-25 03:10:52 -0500

Kashyap Kopparam gravatar image
  1. The package configuration is needed for all nodes. This will enable openstack packages to be installed, like keystone, nova etc. All nodes will have at least one package from openstack.
  2. I have used cloud-archive for juno and it works just fine. Is there a particular reason you are using the staging workgroup?
edit flag offensive delete link more

Comments

Depending, I tried using cloud-archive:juno on the w/e and it didn't work, maybe you need to add the trusty-updates first then it will work. to be honest there are a lot of gaps in the docs, I had issues with Glance, now i have issues with Nova (services down and not connecting to compute node) :(

Garysday gravatar imageGarysday ( 2014-11-25 03:51:34 -0500 )edit

Me too. I am now struggling with the so-called famous http500 error issue with glance. Did you also met it?

yuecong1104 gravatar imageyuecong1104 ( 2014-11-26 03:07:13 -0500 )edit

@Garysday: I'm not sure if adding the trusty-updates and then installing glance with cloud-archive would do any good. And yes, there are a whole lot of gaps in the docs, which calls for people like us to fill em up. Please consider contributing to the docs whenever possible. Thanks.

Kashyap Kopparam gravatar imageKashyap Kopparam ( 2014-11-26 03:58:56 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-11-25 00:55:21 -0500

Seen: 281 times

Last updated: Nov 25 '14