Ask Your Question
1

lbaas configuration in havana multi-node setup [closed]

asked 2014-11-24 22:14:19 -0600

amitabh sinha gravatar image

updated 2014-11-25 00:58:00 -0600

RHK gravatar image

Steps followed by me to configure lbaas in havana multi-node (12.04 LTS)

 1. apt-get install neutron-lbaas-agent

2.vi /etc/neutron/neutron.conf 

service_provider = LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default


3.vi /etc/neutron/neutron.conf 
        service_plugins = lbaas 


4.vi /etc/neutron/lbaas_agent.ini 
       device_driver = neutron.services.loadbalancer.drivers.haproxy.namespace_driver.HaproxyNSDriver


5.vi /etc/neutron/lbaas_agent.ini 
       interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver



6.restarting the neutron-server and neutron-lbaas-agent services.

Enable load balancing in the Project section of the dashboard.
  on Ubuntu 

 7.vi /etc/openstack-dashboard/local_settings.py    
  OPENSTACK_NEUTRON_NETWORK = {
  'enable_lb': True,
  ...
  }

BUT provider is not showing in dashboard. I have attached scrrenshot please go through it.[Screenshot from 2014-11-25 09:25:48.png](/upfiles/14168888472680341.png)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by amitabh sinha
close date 2015-02-04 07:41:27.116891

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-25 05:56:11 -0600

bishoy gravatar image

Your conf is correct I can see any problems in it. Could you check the logs for errors in apache and neutron lbaas.

Also, Could you restart your memcached prior to restarting apache. Also try to open it in a different browser or in private browsing.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-24 22:14:19 -0600

Seen: 188 times

Last updated: Nov 25 '14