default security group not applied on instance start [closed]

asked 2013-09-25 18:00:00 -0500

R0peE gravatar image

updated 2013-09-26 17:42:22 -0500

smaffulli gravatar image

My main problem is that if I launch an instance, the default security group is not applied even though it is checkd in by default. The other problem is, when the instance is launched, on my compute nodes i loose connectivity to the instances. I have to swap out then swap in the security group, and everything is okay. The instances start normally, they get ip address, they have connectivity.

I used this guide to set up my openstack multinode installation: https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/blob/OVS_MultiNode/OpenStack_Grizzly_Install_Guide.rst

This is my quantum.conf: http://pastebin.com/YhwBpNca

And this is my ovs_quantum_plugin.ini: http://pastebin.com/N0bJ2z4B

And for the end nova.conf network stuff: http://pastebin.com/t92rjvk4

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-09-22 14:06:20.375165

Comments

The required settings are here https://ask.openstack.org/en/question/4272/ .

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-09-26 03:22:37 -0500 )edit

Thank you for the comment, but if I do what they suggest, there is absoluteley no connection, with or without the default group, it's like it don't even exists.. :-(

R0peE gravatar imageR0peE ( 2013-09-26 10:18:04 -0500 )edit

I don't know. Did you fix your nova.conf? Did you apply the settings to all nodes?

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-09-26 11:08:45 -0500 )edit

Yes, I applied it, but after that blackout.., I'm googleing for this problem almost a week now, and no solution, not even a similar case, so I could start debuging.

R0peE gravatar imageR0peE ( 2013-09-26 11:14:39 -0500 )edit

I donno. Could be that you have added the rules to the nova default security group, but you are booting with the quantum default security group. Also remember that each tenant has their own quantum security group named "default" - I guess it's the same for nova.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-09-27 10:28:47 -0500 )edit