Ask Your Question
0

What is possible cause that allowed_address_pairs with netmask does not work?

asked 2014-11-22 02:37:38 -0500

samuel.chen gravatar image

Hi, I used below template to create VM with allowed_address_pairs. It does not work on CentOS 7. (ml2 + vlan). VM can't set up IP address.

  But when I set ip_address as ip(192.168.90.1). It is OK. 
  Both two formats are ok on IceHouse (ml2 + vlan).

heat_template_version: '2013-05-23' description: '' parameters: system_name: type: string label: 'System Name' description: '' default: vm001

_template_version_:
    type: string
    default: '1.0'
    hidden: 'True'

resources: 'node:server': type: 'OS::Nova::Server' properties: name: { get_param: system_name } availability_zone: zone1 image: Test flavor: m1.xlarge networks: - port: get_resource: 'network:oam90'

'network:oam90':
    type: 'OS::Neutron::Port'
    properties:
        name: 'MY:network:oam90'
        network_id: cde03605-040d-48c5-a42c-3b80ebf5807d
        allowed_address_pairs:
            -
                ip_address: 192.168.90.0/8
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-11-24 04:52:27 -0500

samuel.chen gravatar image

Same issue as bug https://bugs.launchpad.net/neutron/+bug/1382562 (https://bugs.launchpad.net/neutron/+b...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-22 02:37:38 -0500

Seen: 436 times

Last updated: Nov 24 '14