Ask Your Question
2

mongodb.pp error when installing RDO on CentOS 7

asked 2014-11-21 05:27:03 -0500

Simply_Seth gravatar image

updated 2014-11-25 13:27:35 -0500

smaffulli gravatar image

Kernel: 3.10.0-123.9.3.el7.x86_64

The command I run is

sudo packstack --allinone --provision-all-in-one-ovs-bridge=n

The error I see is:

ERROR : Error appeared during Puppet run: 200.7.4.253_mongodb.pp Error: Could not start Service[mongodb]: Execution of '/usr/bin/systemctl start mongod' returned 1: Job for mongod.service failed. See 'systemctl status mongod.service' and 'journalctl -xn' for details. You will find full trace in log /var/tmp/packstack/20141121-030314-aeb3_0/manifests/200.7.4.253_mongodb.pp.log

Versions:

openstack-packstack-2014.2-0.5.dev1316.g733aa73.el7.centos.noarch
openstack-packstack-puppet-2014.2-0.5.dev1316.g733aa73.el7.centos.noarch

More Logs:

dpaste / 37KQAWP

edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
12

answered 2014-11-21 17:18:06 -0500

Gine gravatar image

I also faced this issue today with CentOS 7. :)

I was able to solve it by modifying the Puppet manifest file after Packstack was installed but before I installed OpenStack with Packstack.

What I did was edit /usr/lib/python2.7/site-packages/packstack/puppet/templates/mongodb.pp. I added the value pidfilepath to the mongodb::server class. Specifically I had it point to /var/run/mongodb/mongod.pid which is what systemd is expecting.

After making the changes I was able to install everything successfully.

More on Puppet/mongodb manifest file here: https://forge.puppetlabs.com/puppetlabs/mongodb/readme (https://forge.puppetlabs.com/puppetla...) .

Edit:

After looking at the tags of the original post I would like to note that I was trying to install Icehouse.

edit flag offensive delete link more

Comments

It works fine. Thanks!!

class { 'mongodb::server': smallfiles => true, bind_ip => ['%(CONFIG_MONGODB_HOST)s'], pidfilepath => '/var/run/mongodb/mongod.pid' }

Kenzo gravatar imageKenzo ( 2014-11-22 01:05:37 -0500 )edit

Worked Beautifully. Thanks!

Simply_Seth gravatar imageSimply_Seth ( 2014-11-22 22:51:45 -0500 )edit

Worked great! Thank you!

aludwar gravatar imagealudwar ( 2014-12-07 16:34:27 -0500 )edit
3

answered 2014-11-25 09:04:02 -0500

updated 2014-12-05 09:56:20 -0500

I filed a bug about that, We are actually working on a fix for that !

https://bugzilla.redhat.com/show_bug.cgi?id=1167888


UPDATE - 2014-12-05

The new rpm builds containing the fix for that issue will be available soon from the official repo.

Meanwhile, you can use them from the copr repo:

edit flag offensive delete link more

Comments

Versions in the RDO repo are as follows, so any other workaround should no longer be required

  • openstack-puppet-modules-2014.2.8-1.el7.centos.noarch
  • openstack-packstack-puppet-2014.2-0.13.dev1395.gaabe0a2.el7.centos.noarch
  • openstack-packstack-2014.2-0.13.dev1395.gaabe0a2.el7.centos.noarch
Steve Baker gravatar imageSteve Baker ( 2015-01-19 23:04:41 -0500 )edit
1

answered 2014-11-28 14:47:57 -0500

AlainD gravatar image

I've tried this quick and dirty workaround with success:

cd /var/run/mongodb

ln -s mongodb.pid mongod.pid

Alain

edit flag offensive delete link more

Comments

well thought and simple solution!

Venu Murthy gravatar imageVenu Murthy ( 2014-12-05 05:29:34 -0500 )edit
0

answered 2014-11-21 05:43:39 -0500

dbaxps gravatar image

updated 2014-11-21 14:35:50 -0500

The temporary workarounds are downgrades of mongodb packages:-
http://projects.theforeman.org/issues...

edit flag offensive delete link more

Comments

I believe puppet manifest will try to reconfigure mongodb in its way and it will override the mongodb configuration file which will create the same issue again.

If there is some way that we can edit packstack answer file so packstack simply skip the mongodb installation and configuration. Suggest?

Ram.Meena gravatar imageRam.Meena ( 2014-11-21 05:55:30 -0500 )edit
0

answered 2014-11-21 05:51:41 -0500

Ram.Meena gravatar image

Hi,

I have also faced the same issue today ifself while configuring a CentOS 7 server using PackStack. The issue is because of the mongodb pid file being created by puppet manifest however it is looking for pid file with slightly different name.

It is creating a pid file with name '/var/run/mongodb/mongodb.pid' however it is looking for '/var/run/mongodb/mongod.pid'.

I have tried to resolve the issue by modifying the pid file name in mongodb configuration file however the issue was still there and could not get any help.

So I have installed the mongodb manually and started its service. Then configured the ceilometer manually. I believe it was the last component which packstack was trying to install. Other openstack components were installed already.

This is how I managed to get it working.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2014-11-21 05:27:03 -0500

Seen: 5,504 times

Last updated: Dec 05 '14