Ask Your Question
0

systemctl status neutron-server.service is not started

asked 2014-11-21 02:18:39 -0500

Udaya Sri gravatar image

updated 2014-11-24 01:44:29 -0500

Output occurs : [root@controller ~]# systemctl start neutron-server.service Job for neutron-server.service failed. See 'systemctl status neutron-server.service' and 'journalctl -xn' for details.

systemctl status neutron-server.service
neutron-server.service - OpenStack Neutron Server
Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; enabled)
Active: failed (Result: exit-code) since Fri 2014-11-21 13:19:15 IST; 15s ago
Process: 3119 ExecStart=/usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --log-file /var/log/neutron/server.log (code=exited, status=1/FAILURE)
 Main PID: 3119 (code=exited, status=1/FAILURE)

Nov 21 13:19:15 controller.xxx.com systemd[1]: neutron-server.service: main process exited, code=exited, status=1/FAILURE
Nov 21 13:19:15 controller.xxx.com systemd[1]: Failed to start OpenStack Neutron Server.
Nov 21 13:19:15 controller.xxx.com systemd[1]: Unit neutron-server.service entered failed state.
edit retag flag offensive close merge delete

Comments

1

Post /var/log/neutron/server.log. Could you also format your posts.

dbaxps gravatar imagedbaxps ( 2014-11-21 02:32:16 -0500 )edit

also post following files :

/usr/share/neutron/neutron-dist.conf

/etc/neutron/neutron.conf

/etc/neutron/plugin.ini ~Abhay

Abhay Dandekar gravatar imageAbhay Dandekar ( 2014-11-21 04:27:21 -0500 )edit

var/log/neutron/server.log 2014-11-24 10:56:09.019 6894 ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on controller:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 17 seconds. 2014-11-24 10:56:26.032 6894 INFO oslo.messaging._drivers.impl_rabbit [-] Delaying

Udaya Sri gravatar imageUdaya Sri ( 2014-11-24 00:14:56 -0500 )edit

/usr/share/neutron/neutron-dist.conf [DEFAULT] verbose = True lock_path = $state_path/lock auth_strategy = noauth notification_driver = neutron.openstack.common.notifier.rpc_notifier allow_overlapping_ips = True use_stderr = False api_paste_config = /usr/share/neutron/api-paste.ini

Udaya Sri gravatar imageUdaya Sri ( 2014-11-24 00:24:17 -0500 )edit

notify_nova_on_port_data_changes = False notify_nova_on_port_status_changes = False

    [quotas]

    [agent]
    root_helper = sudo neutron-rootwrap /etc/neutron/rootwrap.conf
Udaya Sri gravatar imageUdaya Sri ( 2014-11-24 00:24:30 -0500 )edit

5 answers

Sort by » oldest newest most voted
1

answered 2014-11-24 02:21:35 -0500

dbaxps gravatar image

updated 2014-11-24 02:29:21 -0500

According to message: var/log/neutron/server.log 2014-11-24 10:56:09.019 6894 ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on controller:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 17 seconds. 2014-11-24 10:56:26.032 6894 INFO oslo.messaging._drivers.impl_rabbit [-] Delaying

You have issues with connection to rabbitmmq-server on Controller
Make sure ( on RH systems ), first :

[root@juno1 ~(keystone_admin)]# systemctl status rabbitmq-server
rabbitmq-server.service - RabbitMQ broker
   Loaded: loaded (/usr/lib/systemd/system/rabbitmq-server.service; enabled)
   Active: active (running) since Mon 2014-11-24 08:00:11 MSK; 3h 15min ago
  Process: 2969 ExecStartPost=/usr/lib/rabbitmq/bin/rabbitmqctl wait /var/run/rabbitmq/pid (code=exited, status=0/SUCCESS)
  Process: 1566 ExecStartPre=/bin/sh -c /usr/lib/rabbitmq/bin/rabbitmqctl status > /dev/null 2>&1 (code=exited, status=2)
 Main PID: 2968 (beam.smp)
   CGroup: /system.slice/rabbitmq-server.service
           ├─2968 /usr/lib64/erlang/erts-5.10.4/bin/beam.smp -W w -K true -A30 -P 1048576 -- -root /us...
           ├─5227 inet_gethost 4
           └─5228 inet_gethost 4

Second

[root@juno1 ~(keystone_admin)]# netstat -lnpt | grep 5672
tcp6       0      0 :::5672                 :::*                    LISTEN      2968/beam.smp       
[root@juno1 ~(keystone_admin)]# ps -ef | grep 2968
rabbitmq  2968     1  0 07:59 ?        00:01:12 /usr/lib64/erlang/erts-5.10.4/bin/beam.smp -W w -K true -A30 -P 1048576 -- -root /usr/lib64/erlang -progname erl -- -home /var/lib/rabbitmq -- -pa /usr/lib/rabbitmq/lib/rabbitmq_server-3.1.5/sbin/../ebin -noshell -noinput -s rabbit boot -sname rabbit@juno1 -boot start_sasl -config /etc/rabbitmq/rabbitmq -kernel inet_default_connect_options [{nodelay,true}] -rabbit tcp_listeners [{"auto",5672}] -sasl errlog_type error -sasl sasl_error_logger false -rabbit error_logger {file,"/var/log/rabbitmq/rabbit@juno1.log"} -rabbit sasl_error_logger {file,"/var/log/rabbitmq/rabbit@juno1-sasl.log"} -rabbit enabled_plugins_file "/etc/rabbitmq/enabled_plugins" -rabbit plugins_dir "/usr/lib/rabbitmq/lib/rabbitmq_server-3.1.5/sbin/../plugins" -rabbit plugins_expand_dir "/var/lib/rabbitmq/mnesia/rabbit@juno1-plugins-expand" -os_mon start_cpu_sup false -os_mon start_disksup false -os_mon start_memsup false -mnesia dir "/var/lib/rabbitmq/mnesia/rabbit@juno1"
rabbitmq  5227  2968  0 08:00 ?        00:00:00 inet_gethost 4
root     17790  8414  0 11:16 pts/0    00:00:00 grep --color=auto 2968

You have to have rabbitmq-server running on Controller && port 5672 opened
On Ubuntu Controller troubleshooting rabbitmq follow :
https://ask.openstack.org/en/question...

edit flag offensive delete link more
0

answered 2014-11-27 04:04:26 -0500

Ram.Meena gravatar image

First I would suggest you to verify the 'RabbitMQ status' and make sure that all OpenStack nodes are able to ping/connect with RabbitMQ server.

To verify if RabbitMQ service is running on your rabbit server, run below command : -

#systemctl status rabbitmq-server.service -l

or

#service rabbitmq-server status

To verify the RabbitMQ server status run the below command: -

#rabbitmqctl status

This command should print a detailed output of various information related to AMQP server. If the status is good then you need to make sure that rabbitmq port is allowed to make connection between your openstack nodes through firewall.

On RabbitMQ server you may run the below command to check if your compute node is able to establish connection with rabbit server:-

   # lsof -i :5672|grep 'compute_node_ip'

Make sure that there is no time lag between your openstack node, all the nodes should be synced with a central server time using NTP.

edit flag offensive delete link more
0

answered 2014-11-27 05:50:34 -0500

Kishore Devkate gravatar image

@Eric Xie,

Yet not created this neutron service on any server I just stucked at compute server.

BR, Kishore

edit flag offensive delete link more
0

answered 2014-11-21 09:09:18 -0500

Eric Xie gravatar image

updated 2014-11-21 09:09:49 -0500

hi, 1) check /var/log/neutron/server.log if errors exist; 2) python /usr/bin/neutron-server --debug --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --log-file /var/log/neutron/server.log. Check if errors exist. wish help~

edit flag offensive delete link more

Comments

This is at the log :

ERROR oslo.messaging._drivers.impl_rabbit [-] AMQP server on controller:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 17 seconds.
Udaya Sri gravatar imageUdaya Sri ( 2014-11-23 22:14:07 -0500 )edit
0

answered 2019-01-20 16:44:50 -0500

amer.hwitat gravatar image

I had some problems starting neutron-server.service on OSP 13 it was some added lines by me on plugin.ini and neutron.conf , I removed it and it went smooth to start, ironic is installed too so I have to check now if commands run and Horizon stops sending error messages

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-21 02:18:39 -0500

Seen: 11,969 times

Last updated: Nov 27 '14