Setup Internet Access on Windows Server 2012 Virtual machine

asked 2014-11-20 15:13:28 -0500

Darith gravatar image

Setting up a private Cloud on my University's Openstack Cloud. We are going to install sql server on two windows 2012 server virtual machines. So naturally i want install sql server by downloading it to these machines. I did have internet access, now i do not. The College It say i have something blocked. Do i have to do some configuration to simply get internet access on these servers so i can simply download stuff?

edit retag flag offensive close merge delete

Comments

Note: there's also a Heat template to deploy SQL Server if you want to automate it:

https://github.com/openstack/heat-tem...

alexpilotti gravatar imagealexpilotti ( 2014-11-21 11:33:13 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
1

answered 2014-11-20 21:22:17 -0500

Vinoth gravatar image

Are you able to ping 8.8.8.8 ? If you can ping but not able to open any webpage , the issue must be MTU range.

Default value of MTU is 1500 but in some cases you should adjust it to correct value that suits your environment. In most case MTU 1456 will work.

edit flag offensive delete link more

Comments

Made no difference.

Darith gravatar imageDarith ( 2014-11-22 08:40:55 -0500 )edit

I am not able to ping 8.8.8.8. Any Idea?

sheeraz.raza gravatar imagesheeraz.raza ( 2018-03-14 03:34:49 -0500 )edit
1

answered 2014-11-21 00:11:11 -0500

dbaxps gravatar image
Deployment Windows 2012 R2 Evaluation on RDO ML2&OVS&VXLAN system works fine with MTU=1500.
Only ML2&OVS&GRE configuration requires MTU=1454.
edit flag offensive delete link more
0

answered 2014-12-05 07:40:57 -0500

Darith gravatar image

updated 2014-12-05 07:41:14 -0500

Well, we got this sorted. It turned out my security group was the issue, at least thats' what the openstack admin told me ?!

edit flag offensive delete link more
0

answered 2014-11-21 11:29:32 -0500

alexpilotti gravatar image

Cloudbase-init sets the MTU automatically if your DHCP service provides it as an option.

Otherwise, as @vinoth suggests, make sure to set the MTU manually

edit flag offensive delete link more

Comments

It made no difference.

Darith gravatar imageDarith ( 2014-11-22 08:39:44 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-11-20 15:13:28 -0500

Seen: 969 times

Last updated: Dec 05 '14