Ask Your Question
0

install openvswitch-datapath-dkms error: Linux kernel version newer than 3.12.x is not supported

asked 2014-11-19 20:26:49 -0500

MMC gravatar image

With apt-get install openvswitch-datapath-dkms in Ubuntu 14.04 LTS, I got "Error! Bad return status for module build on kernel: 3.13.0-32-generic (x86_64)".

In the /var/lib/dkms/openvswitch/2.0.2/build/make.log: KMS make.log for openvswitch-2.0.2 for kernel 3.13.0-32-generic (x86_64) checking for Linux source directory... /lib/modules/3.13.0-32-generic/build checking for kernel version... 3.13.11 configure: error: Linux kernel in /lib/modules/3.13.0-32-generic/build is version 3.13.11, but version newer than 3.12.x is not supported

The installation of openvswitch-datapath-dkms shows not supporting kernel after 3.12.x. But, the ICEHOUSE is supposed to support Ubuntu 14.04 which has linux kernel 3.13 How is this issue solved?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-11-19 20:52:33 -0500

MMC gravatar image

I just saw the note: Ubuntu installations using Linux kernel version 3.11 or newer do not require the openvswitch-datapath-dkms package. I then removed the openvswitch-datapath-dkms package.

edit flag offensive delete link more

Comments

I experienced the same issue while trying to fix issue with FreeBSD exlplained https://forums.freebsd.org/threads/freebsd-9-1-release-doesnt-boot-on-kvm.36761/ (here) and https://bugs.launchpad.net/qemu/+bug/1329956 (here). While upgrading kernel, I deleted this package and the problem solved.

redondo-mk gravatar imageredondo-mk ( 2015-11-25 18:17:01 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-19 20:26:49 -0500

Seen: 1,900 times

Last updated: Nov 19 '14