Ask Your Question
1

Ceilometer toggles repeat_actions to false in AlarmCombination

asked 2014-11-19 01:32:42 -0500

mc__ gravatar image

updated 2014-11-19 01:34:26 -0500

I'm trying to set up an autoScaling stack in OpenStack Icehouse. After the normal alarms functions successful, I faced a new challenge in setting up an AlarmCombination.

[As you might know, for autoscaling feature, the repeat_actions attribute must be true, otherwise the alarm is not re-risen when the value is still over the threshold.]
However, although in the HOT each AlarmCombination's repeat_actions is set to true, Ceilometers response to Heat is repeat_actions=False. Any clue what happens? Bug?

Following some logs:

  • HOT template with alarm definitions http://paste.openstack.org/show/134659/
  • from template autogenerated alarms http://paste.openstack.org/show/134660/
  • deleted alarmCombo and manually created alarmCombination in ceilometers CLI works fine http://paste.openstack.org/show/134662/
  • heat-engine.log of creation process http://paste.openstack.org/show/134315/ - have a look at line 4vs12, 17vs25 30vs38

    ceilometer --version 1.0.9
    heat --version 0.2.8

edit retag flag offensive close merge delete

Comments

the whole setup of the stack can be found here: http://nopaste.info/3b79fa6a24.html

mc__ gravatar imagemc__ ( 2014-11-19 04:10:01 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-11-19 06:04:57 -0500

I've tracked this down as a Heat bug, reported here:

https://bugs.launchpad.net/heat/+bug/...

and proposed a fix here:

https://review.openstack.org/135576

edit flag offensive delete link more
0

answered 2014-11-20 00:24:28 -0500

mc__ gravatar image

updated 2014-11-20 00:25:04 -0500

works, thanks.

Am I right, that in this fix, repeat_actions is always set to true, so a manual setting to false does have no effect? (Maybe its not necessary anyway in an alarmCombination?)

edit flag offensive delete link more

Comments

The purpose of the fix is to ensure that the actual value of the repeat_actions property is passed correctly to ceilometer by heat (not to always set this to true).

eglynn@redhat.com gravatar imageeglynn@redhat.com ( 2014-11-20 06:03:39 -0500 )edit

As it happens, true is the default for this property. But when backporting the original fix to stable/juno, I noticed that heat had another bug in juno, that causes it to ignore the default values of some properties. I've backported the fixes for that issue also.

eglynn@redhat.com gravatar imageeglynn@redhat.com ( 2014-11-20 06:05:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-19 01:32:42 -0500

Seen: 180 times

Last updated: Nov 20 '14