Ask Your Question
0

after created br-ex ifup does not work

asked 2014-11-18 20:09:02 -0500

yoshi5409 gravatar image

OS: CentOS 7
OpenStack : Juno


I created ifcfg-br-ex
but after rebooting openstack

ifup doesn't work

# ./ifup ifcfg-enp7s0
Error: either "dev" is duplicate, or "br-ex" is a garbage.
cat: /sys/class/net/enp7s0: Is a directory
cat: br-ex/ifindex: No such file or directory
/etc/sysconfig/network-scripts/ifup-eth: line 273: 1000 + : syntax error: operand expected (error token is "+ ")
ERROR : [/etc/sysconfig/network-scripts/ifup-aliases] Missing config file br-ex.

but , using service network restart , the network came to use on juno



edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-18 23:59:44 -0500

dbaxps gravatar image

updated 2014-11-19 00:27:36 -0500

Syntax is incorrect :

Add to /etc/rc.d/rc.local
ifdown br-ex ;
ifup br-ex ;
service network restart ;

./file.exe point that file.exe is in current directory "."

[root@juno1 ~]# which ifup
/sbin/ifup
edit flag offensive delete link more

Comments

systemctl start rc-local

i added to /etc/rc.d/rc.local

ifdown br-ex ;
ifup br-ex ;
service network restart ;

and then

chmod +x /etc/rc.d/rc.local

thank you !!

yoshi5409 gravatar imageyoshi5409 ( 2014-11-19 00:47:39 -0500 )edit

I changed it

# which ifup
/usr/sbin/ifup
# which ifdown
/usr/sbin/ifdown
# which service
/usr/sbin/service

/etc/rc.d/rc.local
touch /var/lock/subsys/local
/usr/sbin/ifdown br-ex ;
/usr/sbin/ifup br-ex ;
/usr/sbin/service network restart ;

yoshi5409 gravatar imageyoshi5409 ( 2014-11-19 01:08:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-18 20:09:02 -0500

Seen: 1,070 times

Last updated: Nov 19 '14