Ask Your Question
3

unable to connect to neutron api

asked 2014-11-18 16:27:20 -0500

boomba gravatar image

Hi guys,

Currently configuring the controller node of neutron as per the link http://docs.openstack.org/trunk/install-guide/install/apt/content/neutron-controller-node.html (http://docs.openstack.org/trunk/insta...)

However when I try to verify the ext-list i receive the following error:

root@Openstack-1:/etc/keystone# neutron ext-list Unable to establish connection to http://Openstack-1:9696/v2.0/extensions.json (http://Openstack-1:9696/v2.0/extensio...)

Does anyone have any clues on why this may occur? I can upload the neutron conf and nova conf is need be.

Thanks

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-10 05:52:14 -0500

warlord gravatar image

hello sir, im having the same problem can you tell me how u solved it. i even configured the network node and tried verifying but the same error Unable to establish connection to http://controller:9696/v2.0/extensions.json (http://controller:9696/v2.0/extension...)

edit flag offensive delete link more
0

answered 2017-03-17 10:12:37 -0500

flno gravatar image

This question is pretty dated, but I had the same error accuring on the Debian Stretch release auf Openstack Neutron. I solved the problem by deleting qos from the service_plugins in /etc/neutron/neutron.conf. It now looks like this: service_plugins = router,metering

After restarting the service the command neutron ext-list showed the desired result.

edit flag offensive delete link more
0

answered 2015-06-13 00:19:31 -0500

whg gravatar image

openstack endpoint delete <endping_id>

openstack endpoint create \

--publicurl http://neutron:9696 \ --adminurl http://neutron:9696 \ --internalurl http://neutron:9696 \ --region RegionOne \ network

then all will be fine

edit flag offensive delete link more
0

answered 2014-11-20 10:22:03 -0500

Vinoth gravatar image

check whether AMQP (rabbit-mq) server is running or not. if it's already running , try restarting the rabbit-mq server & all neutron services.

If you still facing error after the above steps, double check your neutron.conf file for all the entries like rabbit-mq username, password, auth IP.

edit flag offensive delete link more

Comments

I still have this problem.

golestani gravatar imagegolestani ( 2015-05-19 14:04:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-18 16:27:20 -0500

Seen: 5,239 times

Last updated: Mar 17 '17