Ask Your Question
0

multinode neutron vxlan traffic not flolwing between vm and router.

asked 2014-11-18 09:18:11 -0600

alvinstarr gravatar image

I have installed a multinode Juno config using RDO.

I am using VXLAN tunneling between 2 compute nodes to a neutron network node. I can see arp traffic going from the VM to the router and from the VM to the dhcp server but no other traffic seems to be flowing.

If I try to ping from the router to the vm I can see the pings going out the router interface and getting to the tunnel and comming out of the tunnel on the other side but the traffic does not get from the tunnel in the compute node to the actual tap interface on connected to the VM.

I have had a similar configuration working with RDO and Icehouse but with GRE.

edit retag flag offensive close merge delete

Comments

Please, post :

ovs-vsctl show ( on both network node && compute node)
ml2_conf.ini
dbaxps gravatar imagedbaxps ( 2014-11-19 05:24:14 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-19 06:06:41 -0600

alvinstarr gravatar image

updated 2014-11-19 06:11:55 -0600

It turns out that the magic encantation was to downgrade the neutron RPMs I found a redhat bug 1163754 that seems to have fixed this problem up.

edit flag offensive delete link more

Comments

Check:-

# rpm -qa | grep openstack-neutron
openstack-neutron-2014.2-9.el7.centos.noarch
openstack-neutron-openvswitch-2014.2-9.el7.centos.noarch
openstack-neutron-ml2-2014.2-9.el7.centos.noarch
dbaxps gravatar imagedbaxps ( 2014-11-19 07:42:59 -0600 )edit

Check:-

# rpm -qa | grep python-neutron
python-neutron-2014.2-9.el7.centos.noarch
python-neutronclient-2.3.9-1.el7.centos.noarch
dbaxps gravatar imagedbaxps ( 2014-11-19 07:44:11 -0600 )edit

In meantime downgrading like

 yum downgrade openstack-neutron\* python-neutron

is not a solution.

dbaxps gravatar imagedbaxps ( 2014-11-19 07:53:43 -0600 )edit

Are you saying that python-neutronclient is actually the only broken rpm?

alvinstarr gravatar imagealvinstarr ( 2014-11-19 08:36:23 -0600 )edit

I am saying that per https://bugzilla.redhat.com/show_bug....
openstack-neutron-2014.2-9.el7 is fixed. Mentioned bug is not about python-neutronclient.

dbaxps gravatar imagedbaxps ( 2014-11-19 08:49:23 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-18 09:18:11 -0600

Seen: 309 times

Last updated: Nov 19 '14