Ask Your Question
2

Connection to neutron failed: Maximum attempts reached problem [closed]

asked 2014-11-18 02:28:30 -0500

Moe gravatar image

updated 2015-11-24 09:04:50 -0500

When I want to login to horizon I received an error: which is :

Connection to neutron failed: Maximum attempts reached [>>>> logs](http://pastebin.ca/2874324)

my service info and debugs are as bellow:

I am using debian jessie:

root@controller:~# uname -a
Linux controller 3.16-2-amd64 #1 SMP Debian 3.16.3-2 (2014-09-20) x86_64 GNU/Linux
root@controller:~# cat /etc/*version
jessie/sid

my sources.list

root@controller:~# cat /etc/apt/sources.list
deb http://debian.asis.io/debian jessie main
deb http://archive.gplhost.com/debian juno-backports main

my interface list:

root@controller:~# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
    address 10.1.49.104
    netmask 255.255.255.0
    gateway 10.1.49.1
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 8.8.8.8

compute1 :

root@compute1:~# nova service-list
+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+
| Id | Binary           | Host       | Zone     | Status  | State | Updated_at                 | Disabled Reason |
+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+
| 1  | nova-cert        | controller | internal | enabled | up    | 2014-11-18T08:14:11.000000 | -               |
| 2  | nova-conductor   | controller | internal | enabled | up    | 2014-11-18T08:14:10.000000 | -               |
| 4  | nova-compute     | compute1   | nova     | enabled | up    | 2014-11-18T08:14:06.000000 | -               |
| 5  | nova-consoleauth | controller | internal | enabled | up    | 2014-11-18T08:14:11.000000 | -               |
| 6  | nova-scheduler   | controller | internal | enabled | up    | 2014-11-18T08:14:11.000000 | -               |
+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+

controller:

root@controller:~# nova service-list

+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+
| Id | Binary           | Host       | Zone     | Status  | State | Updated_at                 | Disabled Reason |
+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+
| 1  | nova-cert        | controller | internal | enabled | up    | 2014-11-18T07:59:20.000000 | -               |
| 2  | nova-conductor   | controller | internal | enabled | up    | 2014-11-18T07:59:20.000000 | -               |
| 4  | nova-compute     | compute1   | nova     | enabled | up    | 2014-11-18T07:59:15.000000 | -               |
| 5  | nova-consoleauth | controller | internal | enabled | up    | 2014-11-18T07:59:20.000000 | -               |
| 6  | nova-scheduler   | controller | internal | enabled | up    | 2014-11-18T07:59:20.000000 | -               |
+----+------------------+------------+----------+---------+-------+----------------------------+-----------------+

neturon-server service status:

root@controller:~# service neutron-server status
● neutron-server.service - LSB: neutron-server
   Loaded: loaded (/etc/init.d/neutron-server)
   Active: active (exited) since سه‌شنبه 2014-11-18 11:21:40 IRST; 33min ago
  Process: 4335 ExecStop=/etc/init.d/neutron-server stop (code=exited, status=0/SUCCESS)
  Process: 4354 ExecStart=/etc/init.d/neutron-server start (code=exited, status=0/SUCCESS)

نوامبر 18 11:21:40 controller neutron-server[4354]: Starting OpenStack Neutron Server with OpenVSwitch p...er.
Hint: Some lines were ellipsized, use -l to show in full.


root@controller:~# netstat -ntlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      476/sshd        
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1766/exim4      
tcp        0      0 0.0.0.0:35357           0.0.0.0:*               LISTEN      518/python      
tcp        0      0 0.0.0.0:6082            0.0.0.0:*               LISTEN      1819/python     
tcp        0      0 0.0.0.0:8773            0.0.0.0:*               LISTEN      1304/python     
tcp        0      0 0.0.0.0:8774            0.0.0.0:*               LISTEN      1304/python     
tcp        0      0 0.0.0.0:8775            0 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason too localized by Moe
close date 2014-11-18 22:09:06.178765

Comments

Upload somewhere /etc/neutron/neutron.conf

dbaxps gravatar imagedbaxps ( 2014-11-18 03:15:45 -0500 )edit

my problem solved it was an inconsistency between gplhost and debian repositories.

Moe gravatar imageMoe ( 2014-11-18 22:08:38 -0500 )edit

1 answer

Sort by » oldest newest most voted
-1

answered 2014-11-18 14:03:19 -0500

updated 2014-11-18 14:05:33 -0500

Hi Mohammad,

At first check whether your agents are at running state or not:

neutron agent-list

Check whether or not neutron TCP port(9696) is opened or not:

netstat -lnpt | grep 9696

(Make sure that you didn't change the neutron default port to something other than 9696)

Check that the neutron server is running or not:

ps -ef | grep neutron-server

Check your firewall rules, to ensure that there is no rule to filter the requests to neutron:

sudo iptables -L | grep 9696

If the port was not allowed on iptables, try the following command to open it:

iptables -A INPUT -p tcp --dport 9696 -j ACCEPT

If the neutron service was at running state, and your iptables didn't block the 9696 port requests, check the followings:

  • Check the neutron Endpoint at keystone. It might be your neutron endpoint is not registered at keystone(Maybe you missed the step, or it registered incorectly).
  • Check the keystone_authtoken section of your neutron.conf file. It may be keystone credential problems. Checks your credentials.
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-18 02:28:30 -0500

Seen: 4,660 times

Last updated: Nov 24 '15