Ask Your Question
0

Nova instance console error: Failed to connect to server (code: 1006)

asked 2014-11-18 01:37:23 -0500

teju gravatar image

updated 2014-11-18 02:03:36 -0500

I have devstack in CenOS 6.5.

I launched an instance using nova boot command

When I try to access it'sconsole in dashboard, I see Failed to connect to server (code: 1006).

Nova novnc logs: http://pastebin.com/EPygGj6T

i see python version < 2.7.4 does not support novnc as per https://review.openstack.org/#/c/125398/ .

My current python version is 2.6.6

Is it okay to upgrade python in devstack setup?

edit retag flag offensive close merge delete

Comments

Please,run :-

  $ cat /etc/nova/nova.conf | grep novnc
    $ ps -ef | grep consoleauth
    $ ps -ef | grep novncproxy
    $ netstat -lntp | grep 6080
dbaxps gravatar imagedbaxps ( 2014-11-18 02:15:16 -0500 )edit

Aren't you running webproxy ?

dbaxps gravatar imagedbaxps ( 2014-11-18 02:19:36 -0500 )edit
teju gravatar imageteju ( 2014-11-18 03:53:07 -0500 )edit

Check :-
ps -ef | grep 39050

dbaxps gravatar imagedbaxps ( 2014-11-18 03:57:56 -0500 )edit

[root@controller openstack]# ps -ef | grep 39050 root 31122 5797 0 23:28 pts/25 00:00:00 grep 39050 stack 39050 38914 0 20:05 pts/16 00:00:05 /usr/bin/python /usr/bin/nova-novncproxy --config-file /etc/nova/nova.conf --web /opt/stack/noVNC

teju gravatar imageteju ( 2014-11-18 03:59:06 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-11-20 04:39:22 -0500

hectorlopez gravatar image

Hello, I am having the same problem and I follow your last steps(service are running, port is in LISTEN mode), but unfortunately still have the problem.

I can observe in my nova.conf file that the following lines are missing:

novncproxy_host=0.0.0.0 novncproxy_port=6080

So I proceed to add them to the nova.conf and restart all (rejoin-stack.sh)

Unfortunately this doesn't work for me. Could you please advise me what else should I do to get this working?

edit flag offensive delete link more

Comments

If you have the same issue because of python version < 2.7.4, I don't know how to fix it.

teju gravatar imageteju ( 2014-11-20 23:10:32 -0500 )edit

I am using Python 2.6.6

  1. cat /etc/nova/nova.conf | grep novnc: novncproxy_host=0.0.0.0 novncproxy_port=6080 novncproxy_base_url = http://192.168.3.20:6080/vnc_auto.html
hectorlopez gravatar imagehectorlopez ( 2014-11-21 03:10:50 -0500 )edit
  1. ps -ef | grep consoleauth stack 31092 30994 0 Nov20 pts/26 00:00:31 /usr/bin/python /usr/bin/nova-consoleauth --config-file /etc/nova/nova.conf
hectorlopez gravatar imagehectorlopez ( 2014-11-21 03:11:36 -0500 )edit
  1. ps -ef | grep novncproxy

stack 30903 30850 0 Nov20 pts/24 00:00:29 /usr/bin/python /usr/bin/nova-novncproxy --config-file /etc/nova/nova.conf --web /opt/stack/noVNC

hectorlopez gravatar imagehectorlopez ( 2014-11-21 03:12:25 -0500 )edit
  1. netstat -lntp | grep 6080

tcp 0 0 0.0.0.0:6080 0.0.0.0:* LISTEN 30903/python

hectorlopez gravatar imagehectorlopez ( 2014-11-21 03:13:19 -0500 )edit
0

answered 2016-09-15 08:22:59 -0500

addosolutions gravatar image

I realize this is a rather old thread, but for someone (like me) who is still having this issue, this is what I did. I am using Mirantis OpenStack/Fuel 9, on hardware/KVM Ubuntu Trusty 14.x:

The only change I can see that made any difference was to go into the controller node(s) and change the following vnc section (near the end of the file /etc/noca/nova.conf):

[vnc] novncproxy_host=0.0.0.0 novncproxy_port=6080 novncproxy_base_url=http://192.168.0.3:6080/vnc_auto.html

192.168.0.3 is my HA IP, the big change was (I think) adding the host and port. Then restarted using:

/etc/init.d/neutron-server restart

edit flag offensive delete link more

Comments

Hi,

I tried the above. Didn't work for me.

godfrey_tan2001 gravatar imagegodfrey_tan2001 ( 2019-03-14 00:34:41 -0500 )edit
0

answered 2015-01-28 15:20:52 -0500

francois gravatar image

need to check the firewall

Even-though I had disabled the firewall between all nodes

after hours of looking around, tcpdump to the rescue

on the controller node

tcpdump -nni eno1 port 5900

replace eno1 with the management interface , try to launch your vnc-console, you should see a single line computenode:5900

13:55:43.880155 IP 10.0.70.70.45261 > 10.0.70.93.5900: Flags [S], seq 1495139310, win 14600, options [mss 1460,sackOK,TS val 12232244 ecr 0,nop,wscale 7], length 0

Go to the computer node and issue iptables -L you may be surprise as I was to see it was running

Again issues iptables -F to drop all tables. Reload your dashboard and launch your vnc-console again

... and smile (if it was the same problem as mine)

edit flag offensive delete link more

Comments

This worked for me!!!!

Thanks Partha

dashpartha gravatar imagedashpartha ( 2016-06-01 16:54:00 -0500 )edit

worked for me too!!

leewj0726 gravatar imageleewj0726 ( 2017-05-31 07:28:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-11-18 01:37:23 -0500

Seen: 16,228 times

Last updated: Jan 28 '15