Ceilometer not accessible in devstack: 'Connection refused'

asked 2014-11-18 01:32:06 -0500

hanan liaqat bhatti gravatar image

updated 2014-11-21 10:15:33 -0500

smaffulli gravatar image

I am running devstack on ubuntu 12.04 with everything ok except ceilometer. Resource usage icon is present there but when i click it it gives error of

ConnectionError at /admin/metering/
('Connection aborted.', error(111, 'Connection refused'))

I am a beginner so please help out. *my local rc file is**

ADMIN_PASSWORD=mypwd
MYSQL_PASSWORD=mypwd
RABBIT_PASSWORD=mypwd
SERVICE_PASSWORD=mypwd

LOGFILE=$DEST/logs/stack.sh.log
LOGDAYS=2
LOG_COLOR=True
VERBOSE=True
SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5
SWIFT_REPLICAS=1
SWIFT_DATA_DIR=$DEST/data
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-13
enable_service q-meta
enable_service neutron
enable_service q-lbaas
enable_service q-vpn
enable_service q-fwaas
enable_service heat
enable_service h-api
enable_service h-api-cfn
enable_service h-api-cw
enable_service h-eng
enable_service ceilometer-acompute
enable_service ceilometer-acentral
enable_service ceilometer-collector
enable_service ceilometer-api

#enable_service ceilometer-alarm-notify
#enable_service ceilometer-alarm-eval


#for ceilometer alaram configuration.
enable_service ceilometer-alarm-notifier    
enable_service ceilometer-alarm-evaluator

#enable_service tempest

SERVICE_TOKEN=openstack


-------------------------------------------------------
------------------------------------------------------
*************my ceilometer.conf file is***********

[DEFAULT]
os_tenant_name = service
os_password = pwd
os_username = ceilometer

policy_file = /etc/ceilometer/policy.json
debug = True
verbose = True


notification_topics = notifications
rabbit_password = mypwd
rabbit_host = localhost
rpc_backend = ceilometer.openstack.common.rpc.impl_kombu

[keystone_authtoken]
signing_dir = /var/cache/ceilometer
admin_tenant_name = service
admin_password = mypwd
admin_user = ceilometer
auth_protocol = http



[database]
connection = mysql://root:openstack@127.0.0.1/ceilometer?charset=utf8

#connection = mysql://root:openstack@127.0.0.1/ceilometer?charset=utf8

auth_uri = http://10.3.93.35:5000/v2.0
cafile = /opt/stack/data/ca-bundle.pem
identity_uri = http://10.3.93.35:35357

auth_port = 35357
auth_host = 10.3.93.35
edit retag flag offensive close merge delete

Comments

you should edit your question, not post a new one.

smaffulli gravatar imagesmaffulli ( 2014-11-21 10:14:14 -0500 )edit