Ask Your Question
0

Cannot create DB table when installing heat

asked 2014-11-17 21:07:00 -0500

Joe gravatar image

I followed http://docs.openstack.org/icehouse/install-guide/install/apt/content/heat-install.html (here) to install heat (Icehouse). When creating DB tables, the error appeared, as follows.


root@controller:~# su -s /bin/sh -c "heat-manage db_sync" heat No handlers could be found for logger "heat.common.config" 2014-11-17 21:51:58.596 8685 WARNING heat.openstack.common.db.sqlalchemy.session [-] This application has not enabled MySQL traditional mode, which means silent data corruption may occur. Please encourage the application developers to enable this mode. d/usr/lib/python2.7/dist-packages/sqlalchemy/engine/default.py:324: Warning: Specified key was too long; max key length is 767 bytes cursor.execute(statement, parameters)


Mysql version is 14.14 Distrib 5.5.40, for debian-linux-gnu (x86_64) using readline 6.2.

I only found https://bugs.launchpad.net/heat/+bug/1316646 (this bug), but it doesn't seem to be same with my problem. Doesn't Icehouse heat support mysql? Should I use another database for heat? Thanks.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-18 04:47:53 -0500

pas-ha gravatar image

This is (just) a warning, and DB should be operational nevertheless. The LP bug you mention fixed this for MySQL 5.6 where such warnings became errors. Please check that Heat is working - it should be regardless of that warning.

edit flag offensive delete link more

Comments

Yes. It's just a warning. Heat can work well now. Thanks.

Joe gravatar imageJoe ( 2014-11-18 19:33:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-17 21:07:00 -0500

Seen: 472 times

Last updated: Nov 18 '14