Ask Your Question
1

Instance fails to spawn with Unexpected vif_type=binding_failed

asked 2014-11-17 10:09:27 -0600

Truelle gravatar image

updated 2014-11-18 03:14:18 -0600

Hello everyone

I have a similar issue like

https://ask.openstack.org/en/question/48407/instance-failing-to-spawn-logs-show-novaexception-unexpected-vif_typebinding_failed/ (https://ask.openstack.org/en/question...) https://ask.openstack.org/en/question/43813/failed-to-bind-port-in-neutron-on-router/ (https://ask.openstack.org/en/question...) https://ask.openstack.org/en/question/47533/instance-fails-to-spawn-with-unexpected-vif_typebinding_failed/ (https://ask.openstack.org/en/question...) https://ask.openstack.org/en/question/30333/error-unexpected-vif_typebinding_failed/ (https://ask.openstack.org/en/question...)

. My instances dosen't spawn if I configure them with an interface on the external network.

Internal network works fine: instances are spawned and they get full connectivity throught my openstack router on both interfaces.

No errors in logs except

 neutron.plugins.ml2.managers [req-a3d90314-1c7c-443c-98b0-dcc3b4a9e6e6 None] Failed to bind port 86510eae-291c-4cbd-a61a-aeaeb63c6591 on host cdk7

and of course Unexpected vif_type=binding_failed on the compute node.

I tried various fixed from other bugs, but:

Neutron is spawn using the correct config file:

neutron  20429  3.3  0.0 252688 88508 ?        Ss   16:23   0:33 /usr/bin/python /usr/bin/neutron-server --config-file /etc/neutron/neutron.conf --log-file /var/log/neutron/server.log --config-file /etc/neutron/plugins/ml2/ml2_conf.ini

Openvswitch agents are spawn with the correct config file:

neutron  20429  3.3  0.0 252688 88508 ?        Ss   16:23   0:33 /usr/bin/python /usr/bin/neutron-server --config-file /etc/neutron/neutron.conf --log-file /var/log/neutron/server.log --config-file /etc/neutron/plugins/ml2/ml2_conf.ini

Agents:

+--------------------------------------+--------------------+----------+-------+----------------+---------------------------+
| id                                   | agent_type         | host     | alive | admin_state_up | binary                    |
+--------------------------------------+--------------------+----------+-------+----------------+---------------------------+
| 05363c02-a05e-4261-8555-eb7ef2abd812 | DHCP agent         | cdk2 | :-)   | True           | neutron-dhcp-agent        |
| 13b0890d-637f-4879-ae81-65912f2e0849 | Open vSwitch agent | cdk8 | :-)   | True           | neutron-openvswitch-agent |
| 1fa247e1-1517-4a8a-8c0e-619f690176ab | Open vSwitch agent | cdk4 | :-)   | True           | neutron-openvswitch-agent |
| 5e743013-9175-4772-8ce4-4b268e4c72e6 | Open vSwitch agent | cdk6 | :-)   | True           | neutron-openvswitch-agent |
| 6673d3b8-bc81-4158-842a-be98df094978 | Open vSwitch agent | cdk3 | :-)   | True           | neutron-openvswitch-agent |
| 78826bef-49c4-4004-a4bb-c56bacd0dd03 | Open vSwitch agent | cdk5 | :-)   | True           | neutron-openvswitch-agent |
| 965ebaa4-c36f-458f-b6d9-4c9ef48decf1 | Open vSwitch agent | cdk9 | :-)   | True           | neutron-openvswitch-agent |
| aa5eb61b-0a4e-4df1-a839-2978a33fbefa | Open vSwitch agent | cdk0 | :-)   | True           | neutron-openvswitch-agent |
| b1493f13-54a0-4920-bc0d-525a47cce8b4 | L3 agent           | cdk2 | :-)   | True           | neutron-l3-agent          |
| c2e84809-ec0a-45a0-b478-ab08374bc6e0 | Open vSwitch agent | cdk1 | :-)   | True           | neutron-openvswitch-agent |
| e50bf940-1108-46fa-9397-f449f4ee7b63 | Open vSwitch agent | cdk7 | :-)   | True           | neutron-openvswitch-agent |
| fa1d9ce0-2262-4218-b7f4-2fe07571254d | Open vSwitch agent | cdk2 | :-)   | True           | neutron-openvswitch-agent |
| ff3f9c21-70bb-487f-96f2-44c7aabdd35d | Metadata agent     | cdk2 | :-)   | True           | neutron-metadata-agent    |
+--------------------------------------+--------------------+----------+-------+----------------+---------------------------+

External network:

+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | 683e7db6-1fcc-4641-b2f6-e245dfff3406 |
| name                      | ext-net                              |
| provider:network_type     | flat                                 |
| provider:physical_network | external                             |
| provider:segmentation_id  |                                      |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | 2c3c8db0-e2bf-4964-ad1f-4a7fa53f631d |
| tenant_id                 | 4e3dbd665e9e4e99a25322017c205092     |
+---------------------------+--------------------------------------+

The port of the router also is in binding_failed, but works :

(neutron) port-show 5a4df071-c1af-4fdb-a81b-990d707ff242
+-----------------------+-------------------------------------------------------------------------------------+
| Field                 | Value                                                                               |
+-----------------------+-------------------------------------------------------------------------------------+
| admin_state_up        | True                                                                                |
| allowed_address_pairs |                                                                                     |
| binding:host_id       | cdk2                                                                            |
| binding:profile       | {}                                                                                  |
| binding:vif_details   | {}                                                                                  |
| binding:vif_type      | binding_failed                                                                      |
| binding:vnic_type     | normal                                                                              |
| device_id             | f2b5b7d3-5786-42bf-a729-eda2722f307d                                                |
| device_owner          | network:router_gateway                                                              |
| extra_dhcp_opts       |                                                                                     |
| fixed_ips             | {"subnet_id": "2c3c8db0-e2bf-4964-ad1f-4a7fa53f631d", "ip_address": "192.168.1.19"} |
| id                    | 5a4df071-c1af-4fdb-a81b-990d707ff242                                                |
| mac_address           | fa:16:3e:dc:07:10                                                                   |
| name                  |                                                                                     |
| network_id            | 683e7db6-1fcc-4641-b2f6-e245dfff3406                                                |
| security_groups       |                                                                                     |
| status                | DOWN                                                                                |
| tenant_id             |                                                                                     |
+-----------------------+-------------------------------------------------------------------------------------+

ml2_conf.ini for all nodes

[ml2]
type_drivers = flat,gre
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
flat_networks = external
[ml2_type_vlan]
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
[ovs]
local_ip = 192.168.1.22
enable_tunneling = True
tunnel_type = gre
bridge_mappings = external:br-ex # ONLY ON THE NETWORK NODE
[database]
connection = mysql://neutron:x@cdk0/neutron
[agent]
tunnel_types = gre

neutron.conf

[DEFAULT]
verbose = True
lock_path = $state_path/lock
core_plugin = neutron.plugins.ml2.plugin.Ml2Plugin
service_plugins = router
auth_strategy = keystone
allow_overlapping_ips = True
agent_down_time = 75
notify_nova_on_port_status_changes = True
notify_nova_on_port_data_changes = True ...
(more)
edit retag flag offensive close merge delete

Comments

Please post ls -l /etc/neutron and view http://bderzhavets.blogspot.com/2014/...

dbaxps gravatar imagedbaxps ( 2014-11-17 12:17:25 -0600 )edit

I updated the original post with ls' :)

Truelle gravatar imageTruelle ( 2014-11-18 03:14:45 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-18 03:26:39 -0600

dbaxps gravatar image

updated 2014-11-18 03:31:18 -0600

Make following changes to /etc/neutron ( network node) . On Compute plugin.ini should be enough.

 [root@icehouse1 neutron(keystone_admin)]# ls -l
total 72
-rw-r--r--. 1 root root      193 Sep 30 17:08 api-paste.ini
-rw-r-----. 1 root neutron  3901 Sep 30 19:19 dhcp_agent.ini
-rw-r--r--. 1 root root       86 Sep 30 19:20 dnsmasq.conf
-rw-r-----. 1 root neutron   208 Sep 30 17:08 fwaas_driver.ini
-rw-r-----. 1 root neutron  3431 Sep 30 17:08 l3_agent.ini
-rw-r-----. 1 root neutron  1400 Aug  8 02:56 lbaas_agent.ini
-rw-r-----. 1 root neutron  1863 Sep 30 17:08 metadata_agent.ini
lrwxrwxrwx. 1 root root       37 Sep 30 18:41 ml2_conf.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
-rw-r-----. 1 root neutron 19187 Sep 30 17:08 neutron.conf
lrwxrwxrwx. 1 root root       55 Sep 30 18:40 plugin.ini -> /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
-rw-r--r--. 1 root root      211 Sep 30 17:30 plugin.out
drwxr-xr-x. 4 root root     4096 Sep 30 17:08 plugins
-rw-r-----. 1 root neutron  6148 Aug  8 02:56 policy.json
-rw-r--r--. 1 root root       79 Aug 11 15:27 release
-rw-r--r--. 1 root root     1216 Aug  8 02:56 rootwrap.conf

Two files exactly matches. First

[root@icehouse1 neutron(keystone_admin)]# cat ml2_conf.ini
[ml2]
type_drivers = gre
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True
[ovs]
local_ip = 192.168.0.127
[agent]
tunnel_types = gre
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf

Second

[root@icehouse1 neutron(keystone_admin)]# cat plugin.ini
[ml2]
type_drivers = gre
tenant_network_types = gre
mechanism_drivers = openvswitch
[ml2_type_flat]
[ml2_type_vlan]
[ml2_type_gre]
tunnel_id_ranges = 1:1000
[ml2_type_vxlan]
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
enable_security_group = True
[ovs]
local_ip = 192.168.0.127
[agent]
tunnel_types = gre
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf
edit flag offensive delete link more

Comments

Same error :(

I used my ml2_conf.ini since your is removing the external network however :)

Truelle gravatar imageTruelle ( 2014-11-18 03:42:38 -0600 )edit
dbaxps gravatar imagedbaxps ( 2014-11-18 03:55:26 -0600 )edit

Yes, I already checked this :)

Truelle gravatar imageTruelle ( 2014-11-18 04:01:03 -0600 )edit

You wrote : My instances dosen't spawn if I configure them with an interface on the external network
Could you explain what you mean in more details.

dbaxps gravatar imagedbaxps ( 2014-11-18 04:07:10 -0600 )edit

In general, floating IP from external network gets assigned , when instance already got spawn and is active.

dbaxps gravatar imagedbaxps ( 2014-11-18 04:09:08 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-17 10:09:27 -0600

Seen: 1,929 times

Last updated: Nov 18 '14