Ask Your Question
0

Nova-compute failure due to libvirt

asked 2014-11-17 09:47:31 -0500

akh gravatar image

I am not able to launch any instances from either the dashboard or command line. The instances remain in a continuous build state, and it does not give out an error. After checking out the log files on the nova-compute and nova-cloud-controller node I could find the following error in the libvirt.log of compute node.

2014-11-17 13:01:19.200+0000: 5878: error : virNetSocketReadWire:1454 : End of file while reading data: Input/output error

Any suggestion of how this problem could be resolved.

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
0

answered 2014-11-18 03:39:49 -0500

bishoy gravatar image

what is your kernel version and os? I had a similar issue and it was a bug in libvirt or mayb it's a disk issue.

edit flag offensive delete link more

Comments

Kernel version - 3.13.0-35-generic OS - Ubuntu 14.04.1 LTS If it is a disk issue, how did you identify the problem ?

akh gravatar imageakh ( 2014-11-18 03:44:20 -0500 )edit
0

answered 2014-11-17 12:06:28 -0500

Check the status of libvirt-bin service. Using

service libvirt-bin status

Restart the service once and try to boot an instance again. service libvirt-bin restart

edit flag offensive delete link more

Comments

Thanks for the answer, but I am still not able to launch any instances still. Though the error message has changed in the libvirt.log of the compute node:

2014-11-17 18:10:48.677+0000: 5878: error : netcfStateCleanup:109 : internal error: Attempt to close netcf state driver with open connections

akh gravatar imageakh ( 2014-11-17 12:24:56 -0500 )edit

https://www.redhat.com/archives/libvi...

Check if this helps to solve your problem.

TechPatron gravatar imageTechPatron ( 2014-11-17 23:29:27 -0500 )edit

What version of Libvirt gives this errorr ( it's known bug) ?
Please, run :-

# virsh version
dbaxps gravatar imagedbaxps ( 2014-11-18 02:35:13 -0500 )edit

output of virsh version is below, I am searching if it is already reported as a bug,

setlocale: No such file or directory
Compiled against library: libvirt 1.2.2
Using library: libvirt 1.2.2
Using API: QEMU 1.2.2
Running hypervisor: QEMU 2.0.0
akh gravatar imageakh ( 2014-11-18 02:44:34 -0500 )edit

Per http://upstream.rosalinux.ru/changelo...
fixed in 1.1.3 :
Search for entry

Fix leak of objects when reconnecting to QEMU instances
The 'error' cleanup block in qemuProcessReconnect() had a
'return' statement in the middle of it
dbaxps gravatar imagedbaxps ( 2014-11-18 02:46:09 -0500 )edit
0

answered 2014-11-18 03:25:29 -0500

Ram.Meena gravatar image

Hi,

I would also suggest you to change the debug mode 'true' in nova configuration file as below:

debug=True

Restart the nova compute service and check the logs again for more detailed error messages and debugging accordingly.

Since there is a possibility that hypervisor on underlying hardware is not working appropriately so I would suggest you to check if you can create VMs using 'virt-install' command and check if your hypervisor (KVM/QEMU) is working or not. 'virt-install' is a command line tool for provisioning new virtual machines using the "libvirt" hypervisor management library. You may also use the 'virt-manager' if you need GUI to create VM.

edit flag offensive delete link more

Comments

I used the following commands to check if I can create VMs, 1.qemu-img create -f qcow2 /tmp/trusty.qcow2 10G 2.virt-install --virt-type qemu --name trusty --ram 1024 --cdrom=/home/ubuntu/mini.iso --disk /tmp/trusty.qcow2,format=qcow2 --network network=default --graphics vnc,listen=0.0.0.0 --noautoco

akh gravatar imageakh ( 2014-11-18 04:57:07 -0500 )edit

By lowering the ram from 1024 to 256 I was able to initiate the installation process. Though I have not been able to connect to the VM using VNC client, it seems that the underlying hypervisor is working. So I am now trying to free up more memory space to find out, if it is the problem

akh gravatar imageakh ( 2014-11-18 05:28:28 -0500 )edit

You can install 'virt-manager' command to manage the created virtual machines and to access the consoles.

Ram.Meena gravatar imageRam.Meena ( 2014-11-25 04:14:48 -0500 )edit
0

answered 2014-12-19 04:02:34 -0500

Slaan gravatar image

Hi. I have exactly the same error. Can't run any instance :

 {"message": "No valid host was found. ", "code": 500, "details": "  File \"/usr/lib/python2.7/dist-packages/nova/scheduler/filter_scheduler.py\", line 108, in schedule_run_instance |                                      |     raise exception.NoValidHost(reason=\"\")  |

and, within the libvirt.log :

2014-12-18 15:22:31.303+0000: 21920: info : libvirt version: 1.2.2 
2014-12-18 15:22:31.303+0000: 21920: error : virNetSocketReadWire:1454 : End of file while reading data: Input/output error

Did you find the issue ? Many thx.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-17 09:47:31 -0500

Seen: 5,234 times

Last updated: Nov 18 '14