Ask Your Question
2

Instances can't reach external network and Internet

asked 2013-09-24 05:05:36 -0500

Zaino gravatar image

updated 2013-10-11 02:35:14 -0500

I have installed openstack on centos with neutron. The openstack is installed on single virtual machine using vmware.

First i have created external network using following command

quantum net-create public --router:external=True

Then i added my external network subnet (ip pool not used in external network)

Then i created router

Then i set my router gateway to external network

I created security group to allow ssh and icmp.

On second step i created private network with dhcp enabled

Then created router interface and attach it to my private network

On third step i launched the instance with private network

On fourth step i generated floating ip of external network and associates it to instance

Problem Statement:

Virtual machines are getting IP's (private network) from dhcp and communicating with each other but there is No internet on VM's

VM's cannot ping any external network device.

Update: For @darragh-oreilly I am using Centos 6.4. Ip route shows

192.168.186.0/24 dev eth1 proto kernel scope link src 192.168.186.166 metric 1

192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1

10.16.48.0/22 dev br-ex proto kernel scope link src 10.16.51.208

169.254.0.0/16 dev eth0 scope link metric 1002

169.254.0.0/16 dev br-ex scope link metric 1017

default via 10.16.48.1 dev br-ex

Where 10.16.48.0/22 is my external network on eth0 (for internet)

10.16.186.0/24 is my anoother interface on eth1

For @marcelodieder ----+-------+----------------+

| id | agent_type | host | alive | admin_state_up |

+--------------------------------------+--------------------+-----------------------+-------+----------------+

| 4c709a4c-bf0c-4e03-a0f5-2d938fee7ae1 | L3 agent | localhost.localdomain | :-) | True |

| 960a7806-dc4d-4ab1-99b0-a79dbc31600f | Open vSwitch agent | localhost.localdomain | :-) | True |

| d9f545e2-4a6c-43f4-8037-b807cbe27fc5 | DHCP agent | localhost.localdomain | :-) | True |

+--------------------------------------+--------------------+-----------------------+-------+----------------+

edit retag flag offensive close merge delete

Comments

What version of Centos? I know 6.4 did not have IP namespace support. What does 'ip route' show?

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-09-24 11:35:06 -0500 )edit

please see update

Zaino gravatar imageZaino ( 2013-09-25 00:53:07 -0500 )edit

I donno. I thought it might be the double default route that happens when namespaces are not used. You will need to say what guide you are following.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-09-25 04:26:07 -0500 )edit

official redhat documentation for openstack

Zaino gravatar imageZaino ( 2013-09-25 12:47:42 -0500 )edit

Openstack requirement on official redhat website "Software: Red Hat Enterprise Linux (RHEL) 6.4, or the equivalent version of one of the RHEL-based Linux distributions such as CentOS, Scientific Linux, etc"

Zaino gravatar imageZaino ( 2013-09-25 13:00:39 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-10-08 23:49:16 -0500

Zaino gravatar image

Thanks everyone for anticipating i have resolved problem.. Two network interfaces cards were installed in machine. When i configure my external interface card to bridge and restart network services my external network cards seems to disconnected so i reconnects it (through NetworkManager). Reconnect external network will create openstack logical network port in br-int instead of br-ex which will not bridge openstack with external network . The external network card (which is bridged) is used only for virtual machine traffic..It is not used to pass the traffic of host machine. So after configuring the bridge and restart the network services never try to reconnect the external interface.

edit flag offensive delete link more

Comments

Hello , can you tel me whether you have connected the br-ex to the eth which is connected to internet or to other eth ... I am unable to get internet access to vm

shri gravatar imageshri ( 2013-11-22 15:10:58 -0500 )edit

@shri i have connected br-ex to eth0 (which is connected to internet)

Zaino gravatar imageZaino ( 2013-11-27 22:31:32 -0500 )edit

Hi Zaino, Can you please elaborate on the solution you found out. My Instances too cant access internet. I have almost the same setup that you are referring. 2 NIC's, one acting as external interface. i too added did the following 1. gateway of router=public subnet 2. another interface of router=private subnet, 3. restart network My br-ex is still bridged to external interface but VM's cant access internet. Thanks in advance for the help

DeepakRB gravatar imageDeepakRB ( 2014-01-10 08:31:06 -0500 )edit

@Zaino can u share the steps that u followed to resolve the issue . i this i am also stuck with similar issue .. there your solution might be helpful Thanks

lokendra gravatar imagelokendra ( 2015-03-23 04:34:48 -0500 )edit

@Zaino I am also having the same issue could you please help me to resolve the issue which i am facing since long time i am trying it but not working for me....i am using centos 7 in vmware workstation nad created 3 nodes for openstack environment

Kishore Devkate gravatar imageKishore Devkate ( 2015-07-22 00:25:36 -0500 )edit
0

answered 2013-09-24 23:13:21 -0500

marcelodieder gravatar image

updated 2013-09-24 23:13:46 -0500

Neutron is show the agent-list?

# quantum agent-list

edit flag offensive delete link more

Comments

please see update on my question

Zaino gravatar imageZaino ( 2013-09-25 12:45:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2013-09-24 05:05:36 -0500

Seen: 8,061 times

Last updated: Oct 11 '13