Juno Nova compute service cant connect to AMQP server through qpidd whereas there is no issue working with rabbitmq

asked 2014-11-17 01:56:58 -0500

chandra gravatar image

updated 2014-11-17 03:33:16 -0500

smaffulli gravatar image

I am using qpidd instead of rabbitmq in nova-compute and controller node. While starting nova-compute service i see these errors in the nova-compute log. If i use rabbitmq then i dont see these errors and nova-compute is consistently connected to amqp server.

{
2014-11-11 12:17:32.844 5214 DEBUG nova.openstack.common.lockutils [-] Semaphore / lock released "_update_available_resource" inner /opt/stack/nova/nova/openstack/common/lockutils.py:275
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/eventlet/hubs/poll.py", line 115, in wait
    listener.cb(fileno)
  File "/usr/local/lib/python2.7/dist-packages/eventlet/green/select.py", line 52, in on_read
    current.switch(([original], [], []))
  File "/usr/local/lib/python2.7/dist-packages/eventlet/greenthread.py", line 212, in main
    result = function(*args, **kwargs)
  File "/opt/stack/nova/nova/openstack/common/service.py", line 490, in run_service
    service.start()
  File "/opt/stack/nova/nova/service.py", line 181, in start
    self.manager.pre_start_hook()
  File "/opt/stack/nova/nova/compute/manager.py", line 1152, in pre_start_hook
    self.update_available_resource(nova.context.get_admin_context())
  File "/opt/stack/nova/nova/compute/manager.py", line 5964, in update_available_resource
    use_slave=True)
  File "/opt/stack/nova/nova/compute/manager.py", line 5975, in _get_compute_nodes_in_db
    use_slave=use_slave)
  File "/opt/stack/nova/nova/objects/base.py", line 153, in wrapper
    args, kwargs)
  File "/opt/stack/nova/nova/conductor/rpcapi.py", line 346, in object_class_action
    objver=objver, args=args, kwargs=kwargs)
  File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/client.py", line 150, in call
    wait_for_reply=True, timeout=timeout)
  File "/usr/lib/python2.7/dist-packages/oslo/messaging/transport.py", line 90, in _send
    timeout=timeout)
  File "/usr/lib/python2.7/dist-packages/oslo/messaging/_drivers/amqpdriver.py", line 412, in send
    return self._send(target, ctxt, message, wait_for_reply, timeout)
  File "/usr/lib/python2.7/dist-packages/oslo/messaging/_drivers/amqpdriver.py", line 405, in _send
    raise result
IncompatibleObjectVersion_Remote: Version 1.4 of Service is not supported
Traceback (most recent call last):

  File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 133, in _dispatch_and_reply
    incoming.message))

  File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 176, in _dispatch
    return self._do_dispatch(endpoint, method, ctxt, args)

  File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 122, in _do_dispatch
    result = getattr(endpoint, method)(ctxt, **new_args)

  File "/opt/stack/nova/nova/conductor/manager.py", line 1043, in object_class_action

  File "/opt/stack/nova/nova/conductor/manager.py", line 605, in object_class_action
    for t in requested_networks])

  File "/opt/stack/nova/nova/objects/base.py", line 224, in obj_class_from_name

IncompatibleObjectVersion: Version 1.4 of Service is not supported

Removing descriptor: 7
2014-11-11 12:17:32.897 5214 ERROR nova.openstack.common.threadgroup [-] Version 1.4 of Service is not supported
Traceback (most recent call last):

  File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 133, in _dispatch_and_reply
    incoming.message))

  File "/usr/lib/python2.7/dist-packages/oslo/messaging/rpc/dispatcher.py", line 176, in _dispatch
    return self._do_dispatch(endpoint, method, ctxt, args)

  File "/usr/lib/python2 ...
(more)
edit retag flag offensive close merge delete