Ask Your Question
0

juno on CentOS 7 VMs and Neutron - Cirros test images - can't ping the instance [closed]

asked 2014-11-14 21:30:26 -0500

GLaupre gravatar image

updated 2014-11-15 15:54:02 -0500

Hello,

I can't ping my instances that I create on both networks, public and LAN2.

I will try to describe my setup as much as possible.

I am using the stack through devstack. I have 2 VMs runing on CentOS7, one Controller/Network node (os3) and one compute node (os1). The two VMs can ping with each other.

I created a network and I launched a CirrOS instances on it. I got the error on the log: (Already some threads about it and very obscure fixes..)

image description

udhcpc (v1.18.5) started 
Sending discover... 
Sending discover... 
Sending discover... 
No lease, failing 
WARN: /etc/rc3.d/S40network failed

My instance doesn't get any IP. It looks like a DHCP problem.

Well I fix that (obscure) issue by creating a new instance but this time, I did not connect the network on the public one, I have my instance with the IP:

image description

=== network info ===
if-info: lo,up,127.0.0.1,8,::1
if-info: eth0,up,192.168.192.2,20,fe80::f816:3eff:fe8c:8006
ip-route:default via 192.168.192.1 dev eth0 
ip-route:192.168.192.0/20 dev eth0  src 192.168.192.2 
=== datasource: configdrive local ===
instance-id: 5aa9fab2-eb9b-4107-87b7-753831c0f251
name: SmallOnLAN2
availability-zone: nova
local-hostname: smallonlan2.novalocal
launch-index: 0
=== cirros: current=0.3.2 uptime=18.91 ===
=== pinging gateway failed, debugging connection ===
############ debug start ##############
### /etc/init.d/sshd start
Starting dropbear sshd: OK
### ifconfig -a
eth0      Link encap:Ethernet  HWaddr FA:16:3E:8C:80:06  
          inet addr:192.168.192.2  Bcast:192.168.207.255  Mask:255.255.240.0
          inet6 addr: fe80::f816:3eff:fe8c:8006/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:19 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2080 (2.0 KiB)  TX bytes:1692 (1.6 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:112 (112.0 B)  TX bytes:112 (112.0 B)

### route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.192.1   0.0.0.0         UG    0      0        0 eth0
192.168.192.0   0.0.0.0         255.255.240.0   U     0      0        0 eth0
### cat /etc/resolv.conf
search openstacklocal
nameserver 192.168.192.3
### ping -c 5 192.168.192.1
PING 192.168.192.1 (192.168.192.1): 56 data bytes

--- 192.168.192.1 ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss
### pinging nameservers
#### ping -c 5 192.168.192.3
PING 192.168.192.3 (192.168.192.3): 56 data ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by GLaupre
close date 2014-12-02 17:34:32.303174

Comments

My two VMs are actually CentOS 7 machines and I am wondering if the problem is related with the one described here? If yes, I have a starting pt

GLaupre gravatar imageGLaupre ( 2014-11-15 15:20:56 -0500 )edit

Hello GLaupre, I used this post in icehouse to configure a external network and works fine: http://goo.gl/4UXlfz

Then you might change your security rules to open all ports and assign a floating IP to your instance, good luck

Alex Oviedo gravatar imageAlex Oviedo ( 2014-11-15 18:47:53 -0500 )edit

Thanks, I'll try to fix that today.

GLaupre gravatar imageGLaupre ( 2014-11-16 14:23:20 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-11-16 01:27:22 -0500

dbaxps gravatar image
edit flag offensive delete link more

Comments

Thanks dbaxps, I'll take a deep look in it.

GLaupre gravatar imageGLaupre ( 2014-11-16 14:24:14 -0500 )edit

Starting the dnsmasq as root and change the rights on the directory did the trick. I close that thread

GLaupre gravatar imageGLaupre ( 2014-12-02 17:34:12 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-14 21:30:26 -0500

Seen: 1,988 times

Last updated: Nov 16 '14