Ask Your Question
1

keystone AttributeError: 'module' object has no attribute 'load-backends' [closed]

asked 2014-11-14 09:33:02 -0600

Stephanie Fuller gravatar image

updated 2014-11-14 11:39:44 -0600

Error message when I start keystone. I fear I have seriously broken python, (because I had keystone working at one point...) but can't find any clues about 'module' or 'load-backends'. Any suggestions on where to start looking for more info about this problem???

from keystone-startup.log

2014-11-14 09:00:15.675 20096 TRACE keystone   File "/usr/bin/keystone-all", line 125, in <module>
2014-11-14 09:00:15.675 20096 TRACE keystone     service.load_backends()

smafulli, you asked for it...

I am installing based on the 3-node design from docs.openstack.org/icehouse.

On the controller node I installed keystone first, and it was working because I could make the keystone users, services, roles, endpoints, etc...

I then proceeded with image, compute & was working on networking all on the controller node when I started having problems and realized keystone was not working anymore.

When installing glance, I had to rebuild pycrypto with a different gmp. But after that I was still able to create the glance user in keystone and register services and endpoints, etc...

Then I moved on to nova on the control node. yum installed stuff, had some problems with syncing the nova database, but got that resolved. Created nova user in keystone, registered it and service, endpoints, etc... Started noticing the nova-api errors with keystonemiddleware.auth_token. got that resolved.

Moved on to installing/configuring nova on my compute node. No problems noticed.

Moved on to installing neutron on network controller node. Yum installed packages, made database in mysql, added keystone user & service, etc... in keystone. started setting up neutron on network node, installed pkgs, configured neutron.conf, created bridge, messed around with network interfaces and addresses.

Now keystone won't start. Does not make sense. We have had to re-downloaded /usr/lib/python2.6/site_packages/keystone to fix some other python errors. But this one, we can't find anymore info...

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Stephanie Fuller
close date 2014-12-09 10:25:36.111460

Comments

edit the question, add more details about your installation, trace back what changes you applied to your system that may have caused keystone to break

smaffulli gravatar imagesmaffulli ( 2014-11-14 10:46:32 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-09 09:46:22 -0600

Stephanie Fuller gravatar image

Well, no one else seems to know about this either. Anyway, we ditched icehouse and started over with centos7 & juno.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-11-14 09:33:02 -0600

Seen: 528 times

Last updated: Dec 09 '14