Ask Your Question
0

binding_failed in neutron occuring upon VM provision

asked 2014-11-13 01:09:35 -0500

jwitko gravatar image

I am running into an error in neutron where it reports a "binding_failed" when provisioning a VM. I am trying to set up vlan networking and can't figure it out for the life of me. Any help would be greatly appreciated.

Please see errors and config files here: http://pastebin.com/raw.php?i=njziqaFd (If this is not ok I can paste it here but they are rather large)

Please let me know any other information I can provide to assist in helping

edit retag flag offensive close merge delete

Comments

What kind of setup are you targeting ML2&OVS&VLAN or ML2&OVS&VXLAN ?
/etc/neutron/plugins/ml2/ml2_conf.ini && /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini seem strange to me.

dbaxps gravatar imagedbaxps ( 2014-11-13 03:34:37 -0500 )edit

Targetting ML2 & OVS & VLAN

Can you elaborate on what you mean that they "seem strange"?

jwitko gravatar imagejwitko ( 2014-11-13 09:39:48 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-11-13 10:10:12 -0500

dbaxps gravatar image

updated 2014-11-13 10:25:54 -0500

I believe for IceHouse (Juno not tested) ML2&OVSL&VLAN setup requires :-

[root@icehouse1 neutron]# cat plugin.ini
[ml2]
type_drivers = vlan
tenant_network_types = vlan
mechanism_drivers = openvswitch
[ml2_type_vlan]
network_vlan_ranges = physnet1:100:200
[ovs]
network_vlan_ranges = physnet1:100:200
tenant_network_type = vlan
enable_tunneling = False
integration_bridge = br-int
bridge_mappings = physnet1:br-enp5s1
local_ip = 192.168.1.127
[AGENT]
polling_interval = 2
[SECURITYGROUP]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

Interface enp5s1 (CentOS 7) is data/vm

[root@icehouse1 ~(keystone_admin)]# ls -l /etc/neutron
total 60
-rw-r--r--. 1 root root      193 Jul 13 09:06 api-paste.ini
-rw-r-----. 1 root neutron  3853 Jul 13 09:05 dhcp_agent.ini
-rw-r-----. 1 root neutron   208 Jul 13 09:06 fwaas_driver.ini
-rw-r-----. 1 root neutron  3431 Jul 13 09:06 l3_agent.ini
-rw-r-----. 1 root neutron  1400 Jun  8 01:38 lbaas_agent.ini
-rw-r-----. 1 root neutron  1481 Jul 13 09:06 metadata_agent.ini
-rw-r-----. 1 root neutron 19148 Jul 13 09:06 neutron.conf
lrwxrwxrwx. 1 root root       37 Jul 13 09:06 plugin.ini -> /etc/neutron/plugins/ml2/ml2_conf.ini
drwxr-xr-x. 4 root root       34 Jul 13 09:06 plugins
-rw-r-----. 1 root neutron  6148 Jun  8 01:38 policy.json
-rw-r--r--. 1 root root       78 Jun 24 15:14 release
-rw-r--r--. 1 root root     1216 Jun  8 01:38 rootwrap.conf

Details here
Last section in http://pastebin.com/raw.php?i=njziqaFd is targeting VXLAN tunnel configuration
like you want to have VLAN and VXLAN options at a time.

edit flag offensive delete link more

Comments

Thank you, my issue was in the ml2_conf. I did not have the [ovs] settings you described above.

jwitko gravatar imagejwitko ( 2014-11-13 10:59:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-12 23:53:08 -0500

Seen: 94 times

Last updated: Nov 13 '14