ssh can't access instance

asked 2013-04-24 21:31:52 -0600

leo123 gravatar image

I created an openstack cluster on CentOS based on this link " (".

I found I couldn't ssh the instance. That is, I'm stopped at this step: ssh -i oskey.priv root@

After some debugging with VNC on the instance, I figured the public key file has not been imported to the instance. The instance doesn't even have /root/.ssh/ directory. I wonder where I could make mistake and how to solve this problem.

edit retag flag offensive close merge delete


hi, iam facing the same problem the cloudinit did get the key but i can't access with it and there is no ssh dir. did you get any solution for this problem???

bishoy gravatar imagebishoy ( 2013-10-23 10:45:52 -0600 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2013-04-25 04:02:05 -0600

foexle gravatar image

Hi Leo,

if your key are not imported to your instance, the cloud-init package can't communicate with your metadata service. Make sure your routes and/or gateways are all correct configured.

Greetings Heiko

edit flag offensive delete link more


Hi Heiko, Thanks for your reply. How can I check the log of "cloud-init" package communication ? Which port does this communication use ? I was able to ping the new instance. Does that mean the route and/or gateways are OK ?

leo123 gravatar imageleo123 ( 2013-04-25 12:25:35 -0600 )edit

If you can ping your instance it is probably OK. Did you try some other images, like those here: - I'm using CentOS image from here, it works and it is actually 6.4

Alen Komljen gravatar imageAlen Komljen ( 2013-04-25 14:45:18 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2013-04-24 21:31:52 -0600

Seen: 763 times

Last updated: Apr 25 '13