Nova cannot load virtualization driver: No module named vmwareapi [closed]

asked 2013-09-23 16:26:01 -0500

whatson gravatar image

updated 2013-09-23 17:44:23 -0500

smaffulli gravatar image

Hey! I have the following problem when I'm trying to install nova:

2013-09-23 04:37:15 19664 ERROR nova.compute.manager [-] Unable to load the virtualization driver: No module named vmwareapi

My nova.conf looks like the following:

[DEFAULT]
compute_driver=vmwareapi.VMwareVCDriver

# LOGS/STATE
verbose = False
logdir = /var/log/nova
state_path = /var/lib/nova
lock_path = /var/lib/nova/tmp
rootwrap_config = /etc/nova/rootwrap.conf

# SCHEDULER
compute_scheduler_driver=nova.scheduler.filter_scheduler.FilterScheduler

# VOLUMES
# configured in cinder.conf
volume_api_class=nova.volume.cinder.API

# DATABASE
sql_connection = mysql://nova:PASSWORD@192.168.0.105/nova

# COMPUTE
#libvirt_type = vmwareapi
instance_name_template=instance-%08x
enable_instance_password=false

# COMPUTE/APIS: if you have separate configs for separate services
# this flag is required for both nova-api and nova-compute
allow_resize_to_same_host=True

# APIS
enabled_apis=ec2,osapi_compute,metadata
#osapi_compute_extension=nova.api.openstack.compute.contrib.standard_extensions
#ec2_dmz_host=192.168.0.101
#s3_host=192.168.0.101

# QPID
rpc_backend = nova.openstack.common.rpc.impl_qpid
qpid_hostname = 192.168.0.101

# GLANCE
image_service=nova.image.glance.GlanceImageService
glance_api_servers=192.168.0.101:9292

# NETWORK
network_manager = nova.network.manager.FlatDHCPManager
force_dhcp_release = True
dhcpbridge_flagfile = /etc/nova/nova.conf
#dhcpbridge = /usr/bin/nova-dhcpbridge
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
my_ip=192.168.0.101
public_interface=eth0
vlan_interface=eth0
flat_network_bridge=br100
flat_interface=eth0
fixed_range=192.168.100.0/24

# NOVNC CONSOLE
novncproxy_base_url=http://192.168.0.101:6080/vnc_auto.html
# Change vncserver_proxyclient_address and vncserver_listen to match each compute host
vncserver_proxyclient_address=192.168.0.101
vncserver_listen=192.168.0.101

#volumes_dir = /etc/nova/volumes
#injected_network_template = /usr/share/nova/interfaces.template
#libvirt_nonblocking = True
#libvirt_inject_partition = -1
#iscsi_helper = tgtadm
#compute_driver = libvirt.LibvirtDriver

# AUTHENTICATION
auth_strategy = keystone

[vmware]
host_ip = 192.168.0.43
host_username = LAN\Administrator
host_password = PASSWORD
cluster_name= ClusterOne
#wsdl_location=http://192.168.0.101:8080/vmware/SDK/vsphere-ws/wsdl/vim25/vimService.wsdl
#vmwareapi_wsdl_loc=http://192.168.0.101:8080/vmware/SDK/vsphere-ws/wsdl/vim25/vimService.wsdl
wsdl_location=file:///opt/stack/vmware/wsdl/5.0/vimService.wsdl

[keystone_authtoken]
admin_tenant_name = service
admin_user = nova
admin_password = PASSWORD
auth_host = 192.168.0.101
auth_port = 35357
auth_protocol = http
signing_dir = /tmp/keystone-signing-nova

I spent countless hours on searching for the problem on the internet. Maybe somebody in this group will be able to help me.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by smaffulli
close date 2013-09-23 17:45:26.570472

Comments

smaffulli gravatar imagesmaffulli ( 2013-09-23 17:46:08 -0500 )edit

Thanks for your response. I have already read this topic, but it didn't help. Maybe my problem is also related to missing package dependencies, but unfortunately the question wasn't fully answered here: https://ask.openstack.org/en/question/3125/unable-to-load-the-virtualization-driver-no-module-named-vmwareapi/ Therefore I opened this topic.

whatson gravatar imagewhatson ( 2013-09-23 18:00:55 -0500 )edit