IceHouse DashBoard Error on CentOS6.5 - "500 Internal Server Error" [closed]

asked 2014-11-12 09:20:10 -0600

updated 2014-12-10 09:09:05 -0600

Hi Experts,

Thank you for effort to analyse my issue. Please find the below update as per your suggestion. Please advise for further step to fix the Horizon issue.. As per document below are necessary update for the configuration file.

-------------------------
/etc/openstack-dashboard/local_settings
CACHES = {
    'default': {
        'BACKEND' : 'django.core.cache.backends.memcached.MemcachedCache',
        'LOCATION' : '127.0.0.1:11211'
    }
}
ALLOWED_HOSTS = ['*']
OPENSTACK_HOST = "control.labs.com"

-------------------------
/etc/sysconfig/memcached
PORT="11211"
USER="memcached"
MAXCONN="1024"
CACHESIZE="64"
OPTIONS=""

-------------------------
@control ~]# getenforce
Disabled

-------------------------
/var/log/httpd/error_log
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7]     from local.local_settings import *  # noqa
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/local/local_settings.py", line 94, in <module>
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7]     SECRET_KEY = secret_key.generate_or_read_from_file(os.path.join(LOCAL_PATH, '.secret_key_store'))
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7]   File "/usr/lib/python2.6/site-packages/horizon/utils/secret_key.py", line 55, in generate_or_read_from_file
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7]     with lock:
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7]   File "/usr/lib/python2.6/site-packages/lockfile.py", line 223, in __enter__
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7]     self.acquire()
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7]   File "/usr/lib/python2.6/site-packages/lockfile.py", line 239, in acquire
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7]     raise LockFailed("failed to create %s" % self.unique_name)
[Mon Nov 24 18:02:29 2014] [error] [client 192.168.2.7] LockFailed: failed to create /usr/share/openstack-dashboard/openstack_dashboard/local/control.labs.com.Dummy-1-1605

-------------------------
/var/log/httpd/access_log
192.168.2.7 - - [24/Nov/2014:18:02:29 +0530] "GET /dashboard HTTP/1.1" 500 616 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.65 Safari/537.36"
::1 - - [24/Nov/2014:18:04:50 +0530] "GET /dashboard HTTP/1.1" 500 609 "-" "curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.14.0.0 zlib/1.2.3 libidn/1.18 libssh2/1.4.2


-------------------------
[root@control ~]# openstack-status
== Nova services ==
openstack-nova-api:                     active
openstack-nova-cert:                    active
openstack-nova-compute:                 dead      (disabled on boot)
openstack-nova-network:                 dead      (disabled on boot)
openstack-nova-scheduler:               active
openstack-nova-conductor:               active
== Glance services ==
openstack-glance-api:                   active
openstack-glance-registry:              active
== Keystone service ==
openstack-keystone:                     active
== Horizon service ==
openstack-dashboard:                    500
== neutron services ==
neutron-server:                         active
neutron-dhcp-agent:                     inactive  (disabled on boot)
neutron-l3-agent:                       inactive  (disabled on boot)
neutron-metadata-agent:                 inactive  (disabled on boot)
neutron-lbaas-agent:                    inactive  (disabled on boot)
== Support services ==
mysqld:                                 active
messagebus:                             active
qpidd:                                  active
memcached:                              active
== Keystone users ==
+----------------------------------+---------+---------+------------------+
|                id                |   name  | enabled |      email       |
+----------------------------------+---------+---------+------------------+
| fe41229a46784820addebf86f473ee3b |  admin  |   True  |  admin@labs.com  |
| b6a1b46240ad455bab015b66853da06d |  glance |   True  | glance@labs.com  |
| 1c093d12448e444296b3d0217741dd4d | neutron |   True  | neutron@labs.com |
| 50c97e8a6771438b91177a047affe286 |   nova  |   True  |  nova@labs.com   |
+----------------------------------+---------+---------+------------------+
== Glance images ==
+--------------------------------------+---------------------+-------------+------------------+----------+--------+
| ID                                   | Name                | Disk Format | Container Format | Size     | Status |
+--------------------------------------+---------------------+-------------+------------------+----------+--------+
| 833f4815-e691-4ae0-af50-daf94a5298b6 | cirros-0.3 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Pradipta_OS_M
close date 2015-01-10 11:47:28.668597

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-11-12 09:52:31 -0600

please paste the local_setting.py file output here..

edit flag offensive delete link more
0

answered 2014-11-12 09:41:01 -0600

dbaxps gravatar image

updated 2014-11-12 12:36:56 -0600

Try to place comma at the end of "backend" line :-

CACHES = {
    'default': {
        'BACKEND' : 'django.core.cache.backends.locmem.LocMemCache',
        'LOCATION' : '127.0.0.1:11211'
    }
}

Please, view thread https://ask.openstack.org/en/question...
In particular , check /var/log/httpd/error_log.

edit flag offensive delete link more

Comments

Thanks, Updated the comma at the end and restarted httpd and memcached service,, but still getting same error..

192.168.2.7 - - [12/Nov/2014:21:16:19 +0530] "GET /dashboard HTTP/1.1" 500 607 "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3; WOW64; Trident/7.0; .NET4.0E; .NET4.0C; .NET C
Pradipta_OS_M gravatar imagePradipta_OS_M ( 2014-11-12 09:48:50 -0600 )edit

Please, run

$source keystonerc_admin
$openstack-status
As update to question
dbaxps gravatar imagedbaxps ( 2014-11-12 10:25:44 -0600 )edit

try adding this..

Configure auth redirects here accordingly.

LOGIN_URL='/horizon/auth/login/' LOGOUT_URL='/horizon/auth/logout/' LOGIN_REDIRECT_URL='/horizon'

vaibhavhyd2014 gravatar imagevaibhavhyd2014 ( 2014-11-12 10:40:52 -0600 )edit

Please, configure and start services :-

neutron-dhcp-agent
neutron-l3-agent             
neutron-metadata-agent

and try login again.

dbaxps gravatar imagedbaxps ( 2014-12-10 09:34:49 -0600 )edit

Can you run via command line :-

neutron net-list
neutron router-list

Run also :

keystone endpoint-list
dbaxps gravatar imagedbaxps ( 2014-12-10 09:58:26 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-12 09:20:10 -0600

Seen: 1,923 times

Last updated: Dec 10 '14