Ask Your Question
0

Not able to ping private IP

asked 2014-11-11 07:36:06 -0500

prat gravatar image

Hi ,

I have a single node ice-house setup. When I try to bring up a VM, my cirros VM came up completely fine. I have also attached a floating-ip to my VM.

When I am trying to ping VM from my node, I am able to ping to floating-ip but not able to ping to private-ip of VM. I have checked inside the VM, and my private IP is correctly configured on VM's nic.

Any suggestions what can i check ?

Thanks Prat

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-11-11 07:43:43 -0500

uckey gravatar image

Please check your routing table (ex, "$netstat -rn" or "$route -n" ) on your node.

I think there isn't record about private IP on your node.

edit flag offensive delete link more
1

answered 2014-11-11 07:50:42 -0500

dbaxps gravatar image

updated 2014-11-11 07:55:45 -0500

Private IP would will be available for you via corresponding qdhcp-private-net-id namespace. For instance
Ping

[root@juno1 ~(keystone_boris)]# neutron net-list
+--------------------------------------+---------------+-----------------------------------------------------+
| id                                   | name          | subnets                                             |
+--------------------------------------+---------------+-----------------------------------------------------+
| 65cbd354-daae-41bb-9d3c-e58b1062be19 | public        | 147d5ecd-fe39-489e-8901-3b20a2c50148 192.168.1.0/24 |
| 45577666-657d-4f75-a3ab-9bc232f15203 | private_boris | ac209735-54cd-418f-9245-252c56f5eed7 50.0.0.0/24    |
| eb0a79de-1142-4f3c-9fc8-7a63ee565a24 | private       | f58beb24-1e2f-4b00-af55-c1b5ed04d4ad 60.0.0.0/24    |
+--------------------------------------+---------------+-----------------------------------------------------+
[root@juno1 ~(keystone_boris)]# ip netns | grep 45577666-657d-4f75-a3ab-9bc232f15203
qdhcp-45577666-657d-4f75-a3ab-9bc232f15203
[root@juno1 ~(keystone_boris)]# ip netns exec qdhcp-45577666-657d-4f75-a3ab-9bc232f15203 ping -c 3 50.0.0.12
PING 50.0.0.12 (50.0.0.12) 56(84) bytes of data.
64 bytes from 50.0.0.12: icmp_seq=1 ttl=64 time=1.36 ms
64 bytes from 50.0.0.12: icmp_seq=2 ttl=64 time=0.344 ms
64 bytes from 50.0.0.12: icmp_seq=3 ttl=64 time=0.325 ms

--- 50.0.0.12 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2001ms

Login

[root@juno1 ~(keystone_boris)]# ip netns exec qdhcp-45577666-657d-4f75-a3ab-9bc232f15203 ssh -i oskey57.pem fedora@50.0.0.12
The authenticity of host '50.0.0.12 (50.0.0.12)' can't be established.
ECDSA key fingerprint is eb:7c:92:2a:1e:4e:cd:d7:c8:5d:77:8e:f7:f3:d5:fd.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '50.0.0.12' (ECDSA) to the list of known hosts.
Last login: Tue Nov 11 06:39:08 2014
[fedora@vf20rx520711 ~]$ uname -a
Linux vf20rx520711.novalocal 3.16.7-200.fc20.x86_64 #1 SMP Thu Oct 30 18:12:41 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
[fedora@vf20rx520711 ~]$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 50.0.0.12  netmask 255.255.255.0  broadcast 50.0.0.255
        inet6 fe80::f816:3eff:fe5e:939b  prefixlen 64  scopeid 0x20<link>
        ether fa:16:3e:5e:93:9b  txqueuelen 1000  (Ethernet)
        RX packets 19755  bytes 23178851 (22.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 13487  bytes 3541164 (3.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 25588  bytes 13111345 (12.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 25588  bytes 13111345 (12.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
edit flag offensive delete link more

Comments

Thanks much, it worked.

Can you tell me, how to make it work without netns command, I mean, is there anyway that we can just give "ping <private_ip_address>" and it works ?

Thanks Prat

prat gravatar imageprat ( 2014-11-11 08:01:30 -0500 )edit

See this docs https://www.hastexo.com/system/files/...
It's about neutron openstack flow. You may replace GRE by VXLAN . Core idea of this manual will be still correct.

dbaxps gravatar imagedbaxps ( 2014-11-11 08:28:39 -0500 )edit

please run following command ' sudo ip route add <private-ip> via <q-router-gwaddress> dev br-ex '

uckey gravatar imageuckey ( 2014-11-11 18:13:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-11-11 07:36:06 -0500

Seen: 2,793 times

Last updated: Nov 11 '14