Ask Your Question
1

neutron net-create failed

asked 2014-11-11 01:28:05 -0500

yoshi5409 gravatar image

updated 2014-11-11 02:00:29 -0500

Hi

openstack : juno
os : CentOS 7

after i modified /etc/neutron/plugin.ini
from tenant_network_types = vxlan to vlan

and using neutron net-create net1 which was failed .

i saw this messages ( /var/log/neutron/server.log)

2014-11-11 15:49:45.511 4406 INFO neutron.wsgi [-] (4406) accepted (xxx.xxx.xxx.xxx, 54998) <br>
2014-11-11 15:49:45.593 4406 ERROR neutron.api.v2.resource [req-9668af0e-36d4-4d18-aebe-ff407d7ab168 None] create failed <br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource Traceback (most recent call last): <br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/api/v2/resource.py", line 87, in resource<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource     result = method(request=request, **args)<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/api/v2/base.py", line 448, in create<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource     obj = obj_creator(request.context, **kwargs)<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/plugin.py", line 498, in create_network<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource     tenant_id)<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/managers.py", line 160, in create_network_segments<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource     segment = self.allocate_tenant_segment(session)<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource   File "/usr/lib/python2.7/site-packages/neutron/plugins/ml2/managers.py", line 192, in allocate_tenant_segment<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource     raise exc.NoNetworkAvailable()<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource NoNetworkAvailable: Unable to create the network. No tenant network is available for allocation.<br>
2014-11-11 15:49:45.593 4406 TRACE neutron.api.v2.resource<br>
2014-11-11 15:49:45.594 4406 INFO neutron.wsgi [req-9668af0e-36d4-4d18-aebe-ff407d7ab168 None] xxx.xxx.xxx.xxx- - [11/Nov/2014 15:49:45] "POST /v2.0/networks.json HTTP/1.1" 503 360 0.081572<br>

befor i modified plugin.ini , i succeeded .
please tell me what i have to do to solve this matter

○Add ml2_conf.ini○
[ml2]
type_drivers = local,flat,vlan,gre,vxlan
tenant_network_types = vlan
mechanism_drivers =openvswitch
[ml2_type_flat]
[ml2_type_vlan]
network_vlan_ranges = phynet1
bridge_mappings = phynet1:br-ex
[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =10:100
vxlan_group =224.0.0.1
[securitygroup]
enable_security_group = True

edit retag flag offensive close merge delete

Comments

Please, post version /etc/neutron/plugins/ml2/ml2_conf.ini which you have used for "vlan".

dbaxps gravatar imagedbaxps ( 2014-11-11 01:41:51 -0500 )edit

hi dbaxps
I attached ○Add ml2_conf.ini○
I want to use vlan on neutron , but CLI doesn't work
I created network for vlan with openstack's Horaizon

yoshi5409 gravatar imageyoshi5409 ( 2014-11-11 02:04:35 -0500 )edit

3 answers

Sort by » oldest newest most voted
1

answered 2014-11-12 00:34:33 -0500

yoshi5409 gravatar image

we have to change /etc/neutron/plugin.ini

sample configuration /etc/neutron/plugin.ini
[ml2]
type_drivers = local,flat,vlan,gre,vxlan
tenant_network_types = vxlan
mechanism_drivers =openvswitch
[ml2_type_flat]

[ml2_type_vlan]
network_vlan_ranges = phynet1:1000:2999 => add
bridge_mappings = phynet1:br-ex => add

tenant_network_types = vlan => add

[ml2_type_gre]
[ml2_type_vxlan]
vni_ranges =10:100
vxlan_group =224.0.0.1
[securitygroup]
enable_security_group = True

edit flag offensive delete link more
1

answered 2014-11-11 02:39:32 -0500

dbaxps gravatar image

Forced to use answer field due to formatting options.
Following bellow ml2_conf.ini file for IceHouse, p4p1 supports data/network

[root@icehouse1 neutron]# cat plugin.ini
[ml2]
type_drivers = vlan
tenant_network_types = vlan
mechanism_drivers = openvswitch
[ml2_type_vlan]
network_vlan_ranges = physnet1:100:200
[ovs]
network_vlan_ranges = physnet1:100:200
tenant_network_type = vlan
enable_tunneling = False
integration_bridge = br-int
bridge_mappings = physnet1:br-p4p1
local_ip = 192.168.1.127
[AGENT]
polling_interval = 2
[SECURITYGROUP]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
edit flag offensive delete link more

Comments

I knew the reason why i didn't create vlan network by neutron it was not enough configuration
I added "tenant_network_type = vlan" in [ml2_type_vlan] section
therefor I created vlan network using neutron cli

yoshi5409 gravatar imageyoshi5409 ( 2014-11-11 22:25:47 -0500 )edit
0

answered 2017-06-22 05:49:37 -0500

cshen gravatar image

Enable debug=True in /etc/neutron/neutron.conf and restart neutron service.

Try to run the CLI again, and find the debug info in the logfile.

We used this way and found out a quota issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-11 01:28:05 -0500

Seen: 7,941 times

Last updated: Jun 22 '17