Ask Your Question
0

I created br-ex and reboot the openstack , I found physical device which is not link up

asked 2014-11-11 01:15:00 -0500

yoshi5409 gravatar image

updated 2014-11-11 02:56:27 -0500

Hi
I created br-ex for openstack
○Filename (ifcfg-br-ex)
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=xxx.xxx.xxx.xxx
NETMASK=xxx.xxx.xxx.xxx
DNS1=xxx.xxx.xxx.xxx
ONBOOT=yes

○physnet (ifcfg-ens192)
TYPE=Ethernet
BOOTPROTO=static
DEFROUTE=no
PEERDNS=no
PEERROUTES=no
IPV4_FAILURE_FATAL=no
IPV6INIT=no
IPV6_AUTOCONF=no
IPV6_DEFROUTE=no
IPV6_PEERDNS=no
IPV6_PEERROUTES=no
IPV6_FAILURE_FATAL=no
NAME=ens192
ONBOOT=yes
DEVICETYPE=ovs
TYPE=OVSPort
OVS_BRIDGE=br-ex

after rebooting the system , br-ex is linked up not physnet(ens192)
i think both br-ex and physnet is up
On using systemctl restart network , i can see physnet which is linked up .
please tell me , Are these configration correct ?


#I modified ifcfg-ens192 and br-ex
HWADDR=00:50:56:B3:AC:AB
TYPE=Ethernet
BOOTPROTO=static
DEFROUTE=no
PEERDNS=no
PEERROUTES=no
IPV4_FAILURE_FATAL=no
IPV6INIT=no
IPV6_AUTOCONF=no
IPV6_DEFROUTE=no
IPV6_PEERDNS=no
IPV6_PEERROUTES=no
IPV6_FAILURE_FATAL=no
NAME=ens192
ONBOOT=yes
DEVICETYPE=ovs
TYPE=OVSPort
OVS_BRIDGE=br-ex
NM_CONTROLLED=no

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=xxx.xxx.xxx.xxx
NETMASK=xxx.xxx.xxx.xxx
DNS1=xxx.xxx.xxx.xxx
ONBOOT=yes
NM_CONTROLLED=no

after that , systemctl disable NetworkManager
I could see NetworkManager which was stopped
NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; disabled)
Active: inactive (dead)

and chkconfig
network 0:off 1:off 2:on 3:on 4:on 5:on 6:off

right after rebooting system

#ifconfig
br-ex: flags=4163<up,broadcast,running,multicast> mtu 1500
inet xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx broadcast xxx.xxx.xxx.xxx
inet6 fe80::250:56ff:feb3:acab prefixlen 64 scopeid 0x20<link>
ether 00:50:56:b3:ac:ab txqueuelen 0 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 53 bytes 4895 (4.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

ens160: flags=4163<up,broadcast,running,multicast> mtu 1500
inet xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx broadcast xxx.xxx.xxx.xxx
inet6 fe80::250:56ff:feb3:2bfc prefixlen 64 scopeid 0x20<link>
ether 00:50:56:b3:2b:fc txqueuelen 1000 (Ethernet)
RX packets 4904 bytes 342390 (334.3 KiB)
RX errors 0 dropped 80 overruns 0 frame 0
TX packets 37 bytes 4727 (4.6 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<up,loopback,running> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 1719 bytes 160065 (156.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1719 bytes 160065 (156.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

#ovs-vsctl show
668e9944-474d-43e0-9454-49f11febdefa
Bridge br-int
fail_mode: secure
Port br-int
Interface br-int
type: internal
Port patch-tun
Interface patch-tun
type: patch
options: {peer=patch-int}
Bridge br-tun
Port patch-int
Interface patch-int
type: patch
options: {peer=patch-tun}
Port br-tun
Interface br-tun
type: internal ...

















(more)

edit retag flag offensive close merge delete

Comments

See , my updated answer. I picked up and formatted your text.

dbaxps gravatar imagedbaxps ( 2014-11-11 03:46:12 -0500 )edit

booting CentOS I found these messages
Nov 12 13:58:19 localhost network: + ./ifup ens192 boot
Nov 12 13:58:19 localhost network: Error: either "dev" is duplicate, or "br-ex" is a garbage.
Though I checked '/etc/init.d/network' , this file was not writen about OVSBridge

yoshi5409 gravatar imageyoshi5409 ( 2014-11-11 23:44:27 -0500 )edit

Do I have anything config files for me to use OVSBidge ?

yoshi5409 gravatar imageyoshi5409 ( 2014-11-11 23:45:53 -0500 )edit

2 answers

Sort by » oldest newest most voted
1

answered 2014-11-11 02:02:16 -0500

Roy So gravatar image

I believe you are using CentOS 7 or RHEL 7. By default, network manager controls the network interfaces, and it must have an IP address to bring up the interfaces. (I don't know why) If you don't want the NetManager to manage the specific interface, you can simply add the line "NM_CONTROLLED=no" to your config file.

edit flag offensive delete link more

Comments

I'm using CentOS7
Now I'm using service command not NetManager
but after rebooting , only pyshical netowrk using br-ex was not Linked Up
another physical network was Linked UP

yoshi5409 gravatar imageyoshi5409 ( 2014-11-11 19:37:06 -0500 )edit
0

answered 2014-11-11 01:51:21 -0500

dbaxps gravatar image

updated 2014-11-11 03:45:10 -0500

Try in ifcfg-ens192 :
DEVICE=ens192
NM_CONTROLLED=no ( in both files)

# systemctl disable NetworkManager
# systemctl stop NetworkManager
# chkconfig network on
# service network restart

OK. After service restart network
Your ifconfig && ovs-vsctl show
Looks good for me except VXLAN tunnel entry, which should have IPs , rather then interfaces names.

ens192 became OVS port of OVS bridge br-ex

First

ifconfig
br-ex: flags=4163<up,broadcast,running,multicast> mtu 1500
inet xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx broadcast xxx.xxx.xxx.xxx
inet6 fe80::250:56ff:feb3:acab prefixlen 64 scopeid 0x20<link>
ether 00:50:56:b3:ac:ab txqueuelen 0 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 53 bytes 4895 (4.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

ens160: flags=4163<up,broadcast,running,multicast> mtu 1500
inet xxx.xxx.xxx.xxx netmask xxx.xxx.xxx.xxx broadcast xxx.xxx.xxx.xxx
inet6 fe80::250:56ff:feb3:2bfc prefixlen 64 scopeid 0x20<link>
ether 00:50:56:b3:2b:fc txqueuelen 1000 (Ethernet)
RX packets 4904 bytes 342390 (334.3 KiB)
RX errors 0 dropped 80 overruns 0 frame 0
TX packets 37 bytes 4727 (4.6 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

ens192: flags=4163<up,broadcast,running,multicast> mtu 1500
inet6 fe80::250:56ff:feb3:acab prefixlen 64 scopeid 0x20<link>
ether 00:50:56:b3:ac:ab txqueuelen 1000 (Ethernet)
RX packets 2713 bytes 195664 (191.0 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 43 bytes 3884 (3.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<up,loopback,running> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Local Loopback)
RX packets 1719 bytes 160065 (156.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1719 bytes 160065 (156.3 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Second

#ovs-vsctl show
668e9944-474d-43e0-9454-49f11febdefa
Bridge br-int
fail_mode: secure
Port br-int
Interface br-int
type: internal
Port patch-tun
Interface patch-tun
type: patch
options: {peer=patch-int}
Bridge br-tun
Port patch-int
Interface patch-int
type: patch
options: {peer=patch-tun}
Port br-tun
Interface br-tun
type: internal
Port "vxlan-0a0a72b5"
Interface "vxlan-0a0a72b5"
type: vxlan
options: {df_default="true", in_key=flow, local_ip="ens192", out_key=flow, remote_ip="ens160"}
Bridge br-ex
Port "ens192"
Interface "ens192"
Port br-ex
Interface br-ex
type: internal
ovs_version: "2.1.3"
edit flag offensive delete link more

Comments

hi dbaxps
i did so
but , after rebooting the CentOS , ens192 is not linked up yet
As ens192 is not linked up , i have to restart the network every rebooting

yoshi5409 gravatar imageyoshi5409 ( 2014-11-11 02:19:44 -0500 )edit

the system has two network
one is ens160 which is linked up , the other is ens192 using br-ex for bridge
only br-ex is linked up

yoshi5409 gravatar imageyoshi5409 ( 2014-11-11 02:22:34 -0500 )edit

Please, make UPDATE 1 to your question with current ifconfig && ovs-vsctl show.
What are you running IceHouse or Juno ?

dbaxps gravatar imagedbaxps ( 2014-11-11 02:28:05 -0500 )edit

I'm using Juno
right after service restart network , ens192 came to become linked up
and then i rebooted CentOS , ens192 was not linked up
Do I have to service network restart every rebooting ?

yoshi5409 gravatar imageyoshi5409 ( 2014-11-11 19:40:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-11 01:15:00 -0500

Seen: 2,139 times

Last updated: Nov 11 '14