Ask Your Question
0

Not able to ping external internet access(8.8.8.8) from router namespace

asked 2014-11-10 04:46:53 -0500

prathamesh_deshpande gravatar image

Hello, I have created a 3 node Juno setup with Ubuntu 14.04 trusty using GRE/OVS endpoints and neutron networking.

Referred http://docs.openstack.org/juno/instal... All steps previous to this chapter are verified and working fine.

It is stated you should be able to ping this IP address from any host on your external physical network. I am stuck at this step. My gateway for internet access is 10.1.1.254

I have not yet created instances cause of the warning mentioned in the guide, so not proceeding further.

root@network:~# ifconfig 
br-ex     Link encap:Ethernet  HWaddr 00:0c:29:b0:8d:3b  
          inet addr:10.1.1.234  Bcast:10.1.1.255  Mask:255.255.255.0
          inet6 addr: fe80::81e:6eff:fec1:20d7/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:69699 errors:0 dropped:94 overruns:0 frame:0
          TX packets:1903 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7514397 (7.5 MB)  TX bytes:394349 (394.3 KB)

br-int    Link encap:Ethernet  HWaddr f2:e7:5c:1a:f9:42  
          inet6 addr: fe80::44f0:bfff:fe7d:95b6/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:539 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:47366 (47.3 KB)  TX bytes:690 (690.0 B)

br-tun    Link encap:Ethernet  HWaddr 7e:f4:a8:cd:60:4f  
          inet6 addr: fe80::8cb0:47ff:fe6a:905f/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:648 (648.0 B)

eth0      Link encap:Ethernet  HWaddr 00:0c:29:b0:8d:27  
          inet addr:10.1.1.232  Bcast:10.1.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:feb0:8d27/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:53651 errors:0 dropped:88 overruns:0 frame:0
          TX packets:14209 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5046861 (5.0 MB)  TX bytes:2988552 (2.9 MB)

eth1      Link encap:Ethernet  HWaddr 00:0c:29:b0:8d:31  
          inet addr:192.168.100.3  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:feb0:8d31/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:30 errors:0 dropped:13 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2304 (2.3 KB)  TX bytes:3992 (3.9 KB)

eth2      Link encap:Ethernet  HWaddr 00:0c:29:b0:8d:3b  
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:75755 errors ...
(more)
edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
3

answered 2014-11-11 06:14:38 -0500

Roy So gravatar image

Enable promiscuous mode on the vSwitch if you are running openstack on a nested virtual environment. http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1004099 (http://kb.vmware.com/selfservice/micr...)

edit flag offensive delete link more

Comments

root@network:~# ip netns exec qrouter-c3d10c1a-7a21-41e8-af3f-fa78a5db1786 ping -c4 google.com

    PING google.com (74.125.236.160) 56(84) bytes of data.
    64 bytes from maa03s16-in-f0.1e100.net (74.125.236.160): icmp_seq=1 ttl=58 time=44.0 ms
prathamesh_deshpande gravatar imageprathamesh_deshpande ( 2014-11-11 06:20:33 -0500 )edit
0

answered 2014-11-11 02:26:55 -0500

Roy So gravatar image

you should be able to ping this IP address from any host on your external physical network

You may get the it wrong. For example, if you are using 10.1.1.0/24, the tenant router gateway should occupy the lowest IP address in the floating IP address range, 10.1.1.101. If you configured your external physical network and virtual networks correctly, you should be able to ping this IP address (10.1.1.101) from any host on your external physical network (10.1.1.0/24).

edit flag offensive delete link more

Comments

Hi Roy, thanks for responding. My allocation_pools | {"start": "10.1.1.235", "end": "10.1.1.240"}. So the tenant router gateway is 10.1.1.235. i am not able to ping external GW 10.1.1.254 from 10.1.1.235 and also from 10.1.1.0/24 to 10.1.1.235

prathamesh_deshpande gravatar imageprathamesh_deshpande ( 2014-11-11 06:07:35 -0500 )edit
0

answered 2014-11-11 05:59:25 -0500

prathamesh_deshpande gravatar image

updated 2014-11-11 06:00:21 -0500

One important thing i encountered, does the br-ex must be connected as ovs-vsctl add-port br-ex eth2, here eth2 must be Physical NIC? In my setup, the network node is a VM on an ESXi server and i have created a virtual switch on which the 3 virtual NICs exist. So, i think i need to add a route or iptables rule from the virtual NIC eth2 to the actual physical NIC eth2 ??

Please suggest.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-10 01:56:38 -0500

Seen: 983 times

Last updated: Nov 11 '14