Unable to Create VM in neutron enabled devstack [closed]

asked 2013-09-23 03:02:52 -0500

waqasriaz234 gravatar image

updated 2014-01-22 15:12:25 -0500

Evgeny gravatar image

Hi everyone, I built a devstack machine on Fedora 18 ( https://www.berrange.com/posts/2012/11/19/walk-through-of-running-openstack-on-fedora-17-using-devstack/ )

It successfully built stack and VMs are also created successfully. I used following configurations loaclrc file

disable_service rabbit

enable_service qpid

HOST_IP_IFACE=em1

PUBLIC_INTERFACE=em1

VLAN_INTERFACE=em1

FLAT_INTERFACE=em1

MYSQL_PASSWORD=123

SERVICE_TOKEN=123

SERVICE_PASSWORD=123

ADMIN_PASSWORD=123

LOGFILE=/opt/stack/stack.log

disable_service mysql

enable_service postgresql

I want to use openvswitch and enabled neutron services in localrc file. Although it is built successfully and I can build my own networks and routers too, but it gives error while creating a VM.

What should I do to make VM running with neutron ? I want to use openvswitch and neutron services so I enabled neutron services in localrc file. Although it is built successfully and I can build my own networks and routers too, but it gives error while creating a VM.

Following is my updated localrc file

disable_service rabbit

enable_service qpid

HOST_IP_IFACE=em1

PUBLIC_INTERFACE=em1

VLAN_INTERFACE=em1

FLAT_INTERFACE=em1

disable_service n-net

enable_service q-svc

enable_service q-agt

enable_service q-dhcp

enable_service q-l3

enable_service q-meta

enable_service neutron

enable_service q-lbaas

Q_PLUGIN=openvswitch

MYSQL_PASSWORD=123

SERVICE_TOKEN=123

SERVICE_PASSWORD=123

ADMIN_PASSWORD=123

LOGFILE=/opt/stack/stack.log

disable_service mysql

enable_service postgresql

I have looked into logs but haven't found anything helpful What should I do to make VM running with neutron ?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by smaffulli
close date 2013-09-24 18:45:01.117869

Comments