Ask Your Question
0

neutron-lbaas failed when create VIP

asked 2014-11-07 06:45:04 -0500

iqbal gravatar image

Hello stackers,

I try to implement lbaas on my openstack, I used openstack juno and ubuntu 14.04. When I create VIP i got some error on /var/log/neutron/lbaas-agent.log

2014-11-07 19:40:30.362 2967 ERROR neutron.services.loadbalancer.agent.agent_manager [req-d6cd71c0-9e5e-4d3f-b30e-a11dabdc59f4 None] Create vip 2f6ba111-0485-4767-8764-2499c92fa889 failed on device driver haproxy_ns
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager BridgeDoesNotExist: Bridge br-int does not exist.

The complete log should be

2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager Traceback (most recent call last):
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/services/loadbalancer/agent/agent_manager.py", line 214, in create_vip
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager     driver.create_vip(vip)
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/services/loadbalancer/drivers/haproxy/namespace_driver.py", line 318, in create_vip
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager     self._refresh_device(vip['pool_id'])
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/services/loadbalancer/drivers/haproxy/namespace_driver.py", line 315, in _refresh_device
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager     self.deploy_instance(logical_config)
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/lockutils.py", line 249, in inner
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager     return f(*args, **kwargs)
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/services/loadbalancer/drivers/haproxy/namespace_driver.py", line 311, in deploy_instance
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager     self.create(logical_config)
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/services/loadbalancer/drivers/haproxy/namespace_driver.py", line 91, in create
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager     self._plug(namespace, logical_config['vip']['port'])
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/services/loadbalancer/drivers/haproxy/namespace_driver.py", line 254, in _plug
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager     namespace=namespace
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/agent/linux/interface.py", line 232, in plug
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager     self.check_bridge_exists(bridge)
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager   File "/usr/lib/python2.7/dist-packages/neutron/agent/linux/interface.py", line 168, in check_bridge_exists
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent.agent_manager     raise exceptions.BridgeDoesNotExist(bridge=bridge)
2014-11-07 19:40:30.362 2967 TRACE neutron.services.loadbalancer.agent ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2014-11-07 09:30:57 -0500

iqbal gravatar image

Solve, my bad...install service agent on wrong node T__T.

Btw everything is ok now, but when i want associate pool to monitoring, the list was empty. But when i associate monitoring from command line, everything is ok..

This is bug or I need add extra config?

Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-11-07 06:45:04 -0500

Seen: 432 times

Last updated: Nov 07 '14